Модераторы: stron
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> УПП 1.3 печатная форма ИНВ-1,как вывести должность, Документ Инвентаризация ОС 
:(
    Опции темы
slnes
Дата 23.11.2016, 04:20 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 139
Регистрация: 24.6.2005

Репутация: нет
Всего: нет



УПП 1.3, печатаю документ Инвентаризация ОС, печатная форма ИНВ-1, поле должность пусто и в ответственных лицах и в членах комиссии.
В коде Подпись.Параметры.Должность = СтрокаМОЛ.Должность, есть строка которая долдна выводить должность.
Как вывести должность?
 
PM MAIL   Вверх
Poseidon
Дата 25.11.2016, 08:54 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Delphi developer
****


Профиль
Группа: Комодератор
Сообщений: 5273
Регистрация: 4.2.2005
Где: Гомель, Беларусь

Репутация: нет
Всего: 133



Прием на работу оформлен в 1С? Или просто в справочнике завели нужного сотрудника?


--------------------
Если хочешь, что бы что-то работало - используй написанное, 
если хочешь что-то понять - пиши сам...
PM MAIL ICQ   Вверх
slnes
Дата 25.11.2016, 11:16 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 139
Регистрация: 24.6.2005

Репутация: нет
Всего: нет



Оформлен в 1С. Проблема решена заменой строк с модуле документа Инвентаризация ОС

               
Код

 //ДанныеМОЛ = ОбщегоНазначения.ДанныеФизЛиц(Док.Организация, СписокМОЛ, Док.Дата);
                Если ЗначениеЗаполнено(Док.Организация.ГоловнаяОрганизация) Тогда
                               ДанныеМОЛ = ОбщегоНазначения.ДанныеФизЛиц(Док.Организация.ГоловнаяОрганизация, СписокМОЛ, Док.Дата);
                Иначе
                               ДанныеМОЛ = ОбщегоНазначения.ДанныеФизЛиц(Док.Организация, СписокМОЛ, Док.Дата);
                КонецЕсли;


             //ДанныеПредседателя = ОбщегоНазначения.ДанныеФизЛица(Док.Организация, ПредседательКомиссии.ФизЛицо, Док.Дата);
              Если ЗначениеЗаполнено(Док.Организация.ГоловнаяОрганизация) Тогда
                                 ДанныеПредседателя = ОбщегоНазначения.ДанныеФизЛица(Док.Организация.ГоловнаяОрганизация, ПредседательКомиссии.ФизЛицо, Док.Дата);
                Иначе
                     ДанныеПредседателя = ОбщегоНазначения.ДанныеФизЛица(Док.Организация, ПредседательКомиссии.ФизЛицо, Док.Дата);
                КонецЕсли;

            //ДанныеЧленаКомиссии = ОбщегоНазначения.ДанныеФизЛица(Док.Организация, ЧленКомиссии.ФизЛицо, Док.Дата);
             Если ЗначениеЗаполнено(Док.Организация.ГоловнаяОрганизация) Тогда
                    ДанныеЧленаКомиссии = ОбщегоНазначения.ДанныеФизЛица(Док.Организация.ГоловнаяОрганизация, ЧленКомиссии.ФизЛицо, Док.Дата);
              Иначе
                   ДанныеЧленаКомиссии = ОбщегоНазначения.ДанныеФизЛица(Док.Организация, ЧленКомиссии.ФизЛицо, Док.Дата);
             КонецЕсли;


PM MAIL   Вверх
Google
  Дата 24.9.2017, 09:46 (ссылка)  





  Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "1C: Предприятие, SAP, ERP и учётные системы"
stron

Запрещается!

1. Обсуждение крэков, кейгенов и других подобных программ

Пробуйте искать сами или обращайтесь в приват к участникам форума.

Темы с подобными вещами будут немедленно удаляться, а нарушители - получать предупреждения.

Также запрещается обсуждение проблем работы этих программ (что куда вписать, куда что скопировать и т.п...)

2. Давать ссылки на взломанные продукты

  • Пожалуйста, пользуйтесь поиском перед тем, как задать вопрос - возможно ответ уже есть на форуме.
  • Название темы должно отражать её суть
  • Действия модераторов можно обсудить здесь

С уважением, stron, Pegas.

 
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | 1C: Предприятие, SAP, ERP и учётные системы | Следующая тема »


 




[ Время генерации скрипта: 0.0687 ]   [ Использовано запросов: 20 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.