Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Установка redmine 
:(
    Опции темы
likenix
Дата 19.3.2011, 15:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 66
Регистрация: 13.10.2008

Репутация: нет
Всего: нет



Итак проблема =)

Операционная система Windows XP x64

Захотел я поставить баг трекер redmine ну помучался сначала с установкой по собственной инициативе =)
Делал все по статье http://nightcoder.livejournal.com/6223.html
За исключением нескольких вещей 
1. Я поставил ruby 2.3.11 и потому что прочитал требования для новой версии redline (redmine-1.1.2) тут http://www.redmine.org/projects/redmine/wiki/RedmineInstall. Вобщем это и была инициатива типа а давайте все на новых версиях строить =).

2. У меня никак не хотела подключаться база mysql (rake db:migrate) и я нашел счастливого обладателя такой же поблемы тут  http://railsforum.com/viewtopic.php?pid=107305#p107305 вобщем скачал тот mysqlLib.dll все заработало т.е база мигрировала.

3 rack я постав 1.0.1 вместо 1.1.0 потомучто с 1.1.0 и 2.0.0 тоже была проблема во время мегрирования базы(rake db:migrate)

 
Код
rack(1.1.0 not ~> 1.0.1) (Gem::LoadError)
 Побороть не смог на этапе мегрирования похоже точно уже не помню

4. Возникла проблема на этапе сборки gem install win32-service --platform=mswin3

Код
Fetching: win32-api-1.4.8.gem (100%)
ERROR:  Error installing win32-service:
        The 'win32-api' native gem requires installed build tools.

Please update your PATH to include build tools or download the DevK
from 'http://rubyinstaller.org/downloads' and follow the instructio
at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'


так что пришлось поставить и его версия DevKit-tdm-32-4.5.1-20101214-1400

На всякий случай лист того что установлено:

Код
C:\Ruby187\apps\redmine>gem list

*** LOCAL GEMS ***

actionmailer (2.3.11)
actionpack (2.3.11)
activerecord (2.3.11)
activeresource (2.3.11)
activesupport (2.3.11)
cgi_multipart_eof_fix (2.5.0)
gem_plugin (0.2.3)
i18n (0.4.2)
mongrel (1.1.5 x86-mingw32)
mongrel_service (0.4.0)
mysql (2.8.1 x86-mingw32)
rack (1.0.1)
rails (2.3.11)
rake (0.8.7)
rdiscount (1.6.8)
win32-api (1.4.8)
win32-service (0.7.1 x86-mswin32-60)
windows-api (0.4.0)
windows-pr (1.1.3)


Итого сейчас прекрасно работает если запускать командой ruby script/server webrick -e production

Но не работает если запускать как сервис
В логах:

Код
Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with production environment...
C:/Ruby187/apps/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:10: superclass mismatch for class GemDependency (TypeError)
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
    from C:/Ruby187/apps/redmine/config/../vendor/rails/railties/lib/initializer.rb:10
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
    from C:/Ruby187/apps/redmine/config/boot.rb:45:in `load_initializer'
    from C:/Ruby187/apps/redmine/config/boot.rb:38:in `run'
    from C:/Ruby187/apps/redmine/config/boot.rb:11:in `boot!'
    from C:/Ruby187/apps/redmine/config/boot.rb:122
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
    from C:/Ruby187/apps/redmine/config/environment.rb:20
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/rails.rb:147:in `rails'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:113:in `cloaker_'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:149:in `call'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:149:in `listener'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:99:in `cloaker_'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:50:in `call'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:50:in `initialize'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:84:in `new'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:84:in `run'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/command.rb:212:in `run'
    from C:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:281
    from C:/Ruby187/bin/mongrel_rails:19:in `load'
    from C:/Ruby187/bin/mongrel_rails:19


ЗЫ помогите пока я чиню бубен =)
PM MAIL   Вверх
source777
Дата 20.3.2011, 15:32 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1878
Регистрация: 12.3.2007

Репутация: нет
Всего: 56



Странно, что человек с ником likenix разворачивает Redmine на Windows XP да ещё и на продакшн...  smile 



--------------------
Если бы программистам платили за то, чтобы убирать код из программы вместо того, чтобы добавлять его, программы были бы намного лучше © Николас Негропонте
PM MAIL   Вверх
likenix
Дата 20.3.2011, 18:42 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 66
Регистрация: 13.10.2008

Репутация: нет
Всего: нет



Да вот такое вот бываит =) а то что на продакшн энто просто по статье =) Просто сейчас именно под вин работаю чаще, а точнее почти постоянно а год назад работал под nix постоянно =).

Добавлено через 4 минуты и 5 секунд
Чтож мне теперь ник поменять?)))
PM MAIL   Вверх
source777
Дата 20.3.2011, 19:53 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1878
Регистрация: 12.3.2007

Репутация: нет
Всего: 56



Цитата(likenix @  20.3.2011,  18:42 Найти цитируемый пост)
а то что на продакшн энто просто по статье =) Просто сейчас именно под вин работаю чаще, а точнее почти постоянно а год назад работал под nix постоянно =)

Я так и не понял зачем разворачивать Redmine на собственном компе в production mode и уж тем более под Mongrel...
Если нет своего сервера, то разверни на хостинг какой-нибудь...



--------------------
Если бы программистам платили за то, чтобы убирать код из программы вместо того, чтобы добавлять его, программы были бы намного лучше © Николас Негропонте
PM MAIL   Вверх
Google
  Дата 21.10.2019, 07:48 (ссылка)  





  Вверх
  
Ответ в темуСоздание новой темы Создание опроса
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Ruby: Библиотеки | Следующая тема »


 




[ Время генерации скрипта: 0.0736 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.