Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Qtruby, Вопрос по работе Qtruby и Ruby 1.9.2 
:(
    Опции темы
zov
Дата 17.1.2011, 15:02 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 1
Регистрация: 27.2.2008

Репутация: нет
Всего: нет



У кого-нибудь работает связка Qtruby (qtruby4-2.1.0-mswin32) и Ruby 1.9.2? Мне так и не удалось заставить QtRuby  нормально функционировать. Даже при вводе в irb команды "require "Qt'" возникает ошибка:  "LoadError: no such file to load -- qtruby4".
Боле-менее сносно работает qtruby4-2.1.0-mswin32 и Ruby 1.8.7 (установку проводил как описано здесь:http://smittywerben.wordpress.com/2010/08/28/how-to-install-qtruby4-in-windows-even-with-spaces-in-pathname/), но тоже не идеально, в файле перед "require 'Qt'" обязательно необходимо указывать и "require 'rubygems'" иначе возникает такая же ошибка. Я Ruby занимаюсь всего неделю, многого не знаю, подскажите что не так делаю?
PM MAIL   Вверх
source777
Дата 17.1.2011, 22:10 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1878
Регистрация: 12.3.2007

Репутация: нет
Всего: 56



Цитата(zov @  17.1.2011,  15:02 Найти цитируемый пост)
но тоже не идеально, в файле перед "require 'Qt'" обязательно необходимо указывать и "require 'rubygems'"

Вообще-то require 'rubygems' нужно указывать всегда, когда используешь библиотеку не из стандартной поставки, так что тут всё правильно. Возможно именно этой строки тебе как раз и не хватает для скрипта на Ruby 1.9.2.

А вообще, я бы смотрел в сторону qtbindings, а не qtruby4.

Это сообщение отредактировал(а) source777 - 17.1.2011, 22:10


--------------------
Если бы программистам платили за то, чтобы убирать код из программы вместо того, чтобы добавлять его, программы были бы намного лучше © Николас Негропонте
PM MAIL   Вверх
hexzo
Дата 18.4.2011, 16:02 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 178
Регистрация: 30.1.2011

Репутация: нет
Всего: нет



Цитата(source777 @  17.1.2011,  22:10 Найти цитируемый пост)
А вообще, я бы смотрел в сторону qtbindings, а не qtruby4.

Спасибо за наводку. Оно действительно работает! Без проблем ставится на последнюю версию интерпретатора, ничего дополнительного не требует. И вроде работает, во всяком случае небольшие программки. Там ещё вместе с либой ставятся примеры прог, из кутешных док, переписанные на руби.
PM MAIL   Вверх
Google
  Дата 23.5.2019, 16:00 (ссылка)  





  Вверх
  
Ответ в темуСоздание новой темы Создание опроса
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Ruby: GUI | Следующая тема »


 




[ Время генерации скрипта: 0.1102 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.