Модераторы: JackYF
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> MinGW и отладчик gdb не работает 
:(
    Опции темы
Ilya83
Дата 18.12.2017, 22:07 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 22
Регистрация: 5.1.2014

Репутация: нет
Всего: нет



Помогите решить проблему. Совершенно невозможно пользоваться отладчиком gdb. При запуске отладчика, если перейти в режим просмотре переменных, сразу вылетает сообщение "Signal received: SIGTRAP (Trace/breakpoint trap)". Сейчас делаю так. Прохожу отладчиком до нужного места, затем переключаюсь на просмотр переменных, переключаюсь назад и иду дальше. Там получается пройтись в отладчике несколько строк. Затем все равно вылетает это сообщение. 

Что нужно сделать, чтобы оно не выскакивало ?
PM MAIL   Вверх
xvr
Дата 20.12.2017, 18:02 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
****


Профиль
Группа: Комодератор
Сообщений: 6992
Регистрация: 28.8.2007
Где: Химки, Московская обл

Репутация: нет
Всего: 222



Не должно быть такого. Опишите по шагам, что и как делаете.

PS. А почему MinGW и gdb а не VS? С ней с нуля будет проще, она всё таки более user friendly, чем компания GNU & Unix.

PM MAIL   Вверх
Google
  Дата 16.7.2019, 23:34 (ссылка)  





  Вверх
  
Ответ в темуСоздание новой темы Создание опроса
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | GNU toolchain | Следующая тема »


 




[ Время генерации скрипта: 0.0496 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.