Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Java tools & IDE's > [IntelliJ 13] Unable to ping server at localhost


Автор: linuxoid 16.5.2014, 00:14
Здравствуйте, друзья! Пытаюсь запустить Hello World из серии "Creating a simple Web application for Tomcat in IntelliJ IDEA 12". У меня Windows 64-bit, IntelliJ IDEA 13.0 ULTIMATE. Всё делаю, как в этом туториале:

http://wiki.jetbrains.net/intellij/Creating_a_simple_Web_application_for_Tomcat_in_IntelliJ_IDEA_12

Т.е. по сути всего лишь создаю проект по умолчанию: File -> New Project -> Java -> ставлю галочку Web Application -> Finish. Остальное всё по умолчанию (Tomcat у меня 8.0.5). Далее кликаю правой кнопкой на index.jsp и выбираю Run index.jsp. После этого получаю следующую ошибк:

23:08:57 All files are up-to-date
23:09:00 Compilation completed successfully in 2 sec
23:09:04 Application Server was not connected before run configuration stop, reason:
         Unable to ping server at localhost:1099

Подскажите, пожалуйста, в чем дело? Уже 2 часа не могу разобраться и ничего не нахожу в гугле про это, кроме для MAC'a, где нужно прописать в хостах localhost.

Автор: Pawl 16.5.2014, 09:44
Вот так вот сложновато сказать в чём проблема. Я прикреплю рабочий проект этого прстейшего приложения (у меня idea 13.1, a сервер тоже Tomcat 8.0.5). Посмотрите, разберитесь как там и что. Да, может еще понадобиться указать новый путь к вашей JDK. Это вы сделаете в Project structure -> project -> project JDK.

Автор: linuxoid 16.5.2014, 11:03
Спасибо! К сожалению выдает ту же ошибку, видимо проблема не в проекте :/

Это пример того, что пишется в output'e:

Цитата

"C:\Program Files\Apache Software Foundation\Tomcat 8.0\bin\catalina.bat" run
Artifact untitled:war exploded: Server is not connected. Deploy is not available.
Disconnected from server


* название папки Tomcat 8.0, но версия 8.0.5

Event log:

Цитата

All files are up-to-date
Application Server was not connected before run configuration stop, reason:
        Unable to ping server at localhost:1099


Не понятно, для чего он пингует порт 1099. В настройках я вижу только 1 поле, где указан порт 1099 - "JMX port". HTTP port = 8080.

Автор: Pawl 16.5.2014, 19:08
Цитата(linuxoid @  16.5.2014,  11:03 Найти цитируемый пост)
Application Server was not connected before run configuration stop, reason:        Unable to ping server at localhost:1099

Может быть, tomcat уже запущен каким-то другим приложением? Попробуйте выяснить это и остановить сервер. Если не получится, скачайте zip-дистрибутив tomcat http://tomcat.apache.org/download-80.cgi, распакуйте его куда-нибудь и в настройках проекта задайте новый сервер:user posted image з

Автор: linuxoid 16.5.2014, 21:37
Сделал. Результат тот же. Попробовал добавить сервер Tomcat в Netbeans. Там в табе "Services" попробовал сделать "Start" для сервера Tomcat. Результат:

Вылетает окошко "Error" с сообщением "Starting of tomcat failed". В логах (Netbeans) вообще пусто. Ужас в общем! Тексты ошибок не дают никакой информации о причинах их возникновения.

P.S. так же попробовал Eclipse jee. Там тоже возникли проблемы. Пришлось в ручную добавлять в Java Build Path -> Libraries библиотеку servlet-api.jar из tomcat. Однако, в отличии от IntelliJ и Netbeans, в eclipse jee при нажатии Run для моего hello-world проекта запускается сервер tomcat и открывается браузер с надписью, которую я указал, что говорит о том, что всё рабоает.

P.P.S. в ручную всё рабоает прекрасно. Сервер запускается, позволяет делать deploy через manager и т.д.

Автор: Pawl 16.5.2014, 22:07
Цитата(linuxoid @  16.5.2014,  21:37 Найти цитируемый пост)
Сделал. Результат тот же.

Мистика! smile 
Цитата(linuxoid @  16.5.2014,  21:37 Найти цитируемый пост)
Попробовал добавить сервер Tomcat в Netbeans. Там в табе "Services" попробовал сделать "Start" для сервера Tomcat.

В NetBeans'e вверху есть менюшка "сервис", в ней есть команда "серверы", в которой можно указать TomCat:user posted image
там не надо делать никакой "старт", просто прописать его, указав пользователь и пароль "admin". Да, и в NetBeans'e web-проект надо создавать через команду "создать проект" -> "web-проект" -> "web-приложение"

Автор: linuxoid 17.5.2014, 00:15
Да. Всё выглядит как у Вас. Я даже полностью снёс jdk 8 и netbeans 8 и установил все заново (включая tomcat 8, установил его сюда: C:\dev\apache-tomcat-8.0.5).

Результат запуска web проекта:

Цитата

ant -f C:\\Users\\admin\\Documents\\NetBeansProjects\\WebApplication2 -Dnb.internal.action.name=run.single -Ddirectory.deployment.supported=true -DforceRedeploy=false -Dnb.wait.for.caches=true -Dbrowser.context=C:\\Users\\admin\\Documents\\NetBeansProjects\\WebApplication2\\web\\index.html -Dclient.urlPart=/index.html run
init:
deps-module-jar:
deps-ear-jar:
deps-jar:
library-inclusion-in-archive:
library-inclusion-in-manifest:
compile:
compile-jsps:
Starting Tomcat process...
Waiting for Tomcat...
Starting of Tomcat failed.
C:\Users\admin\Documents\NetBeansProjects\WebApplication2\nbproject\build-impl.xml:1045: Deployment error: Starting of Tomcat failed.
See the server log for details.
BUILD FAILED (total time: 4 seconds)


Самое печальное, что лог пуст и в Netbeans и в папке logs сервера (logs/localhost.2014-05-16.log = 0kb)  smile 

UPDATE: попробовал сначала запустить сервер в ручную, через cmd: C:\dev\apache-tomcat-8.0.5\bin>startup.bat. Затем запустил Netbeans и запустил index.html проекта (правый клик -> Run File). Так работает!

Автор: Pawl 17.5.2014, 07:59
Цитата(linuxoid @  17.5.2014,  00:15 Найти цитируемый пост)
UPDATE: попробовал сначала запустить сервер в ручную, через cmd: C:\dev\apache-tomcat-8.0.5\bin>startup.bat. Затем запустил Netbeans и запустил index.html проекта (правый клик -> Run File). Так работает!

Ну, это не есть хорошо: при разработке чего-нибудь большого заколебаешься каждый раз перезапускать сервер... Даже не знаю в чем дело! smile Может, если ни одна IDE не может самостоятельно запустить сервер, дело в настройках винды? С windows 8 не работал, а вот семёрка всегда по 10 раз переспрашивала "а вы действительно хотите разрешить этому приложению сделать то-то и то-то?", пока я это на отключил...

Автор: linuxoid 17.5.2014, 11:18
Пробовал полностью отрубить Windows Firewall и антивирус. То же самое :/ Не могу 2 дня запустить Hello World ни в 1 IDE smile Видимо придется переустанавливать Windows 7, как вариант или использовать vBox. Свою текущую винду (Windows 7 64-bit) не могу переустанавливать, т.к. это рабочий лаптоп с кучей инфы.

В любом случае СПАСИБО за помощь!!

Автор: Pawl 17.5.2014, 17:23
Цитата(linuxoid @  17.5.2014,  11:18 Найти цитируемый пост)
Пробовал полностью отрубить Windows Firewall и антивирус.

Дело не только в файерволе и антивирусе. Есть еще политики... В любом случае, если решите проблему - отпишитесь, интересно таки узнать в чём там было дело.

Автор: linuxoid 17.5.2014, 21:30
Ok. Сегодня установил "32-bit/64-bit Windows Service Installer" версию. В IntelliJ всё работает. Даже debug режим. В то же время Netbeans ругается, что нужно установить tomcat из архива, чтобы Netbeans мог запускать сервер. Так же я пробовал разные хитрости. К примеру пробовал копировать с заменой tomcat из архива в папку с установленной "32-bit/64-bit Windows Service Installer" версией. После замены файлов на те, что из архива сразу появляется эта ошибка (Unable to ping server at localhost:1099). Так же, наоборот, пробовал переписать с заменой файлы из "32-bit/64-bit Windows Service Installer" версии на версию из архива. Результат так же отрицательный. 

Но теперь хоть IntelliJ работает, как мне хотелось - могу создавать Hello World  веб приложения без проблем. Тем не менее, действительно хочется выяснить в чем проблема с архивной версией и как эту проблему устранить.

Автор: Pawl 18.5.2014, 08:47
Цитата(linuxoid @  17.5.2014,  21:30 Найти цитируемый пост)
Netbeans ругается, что нужно установить tomcat из архива, чтобы Netbeans мог запускать сервер.

В NetBeans есть вариант полной установки, в котором можно установить также встроенный TomCat. Попробуйте скачать эту версию (https://netbeans.org/downloads/ - самая правая на сайте скачки) и установите её. А с архивами да, вопрос интересный! Нет ли у вас доступа к какому-нибудь другому компьютеру с виндой? Можно было бы проверить, как всё работает на нём...

Автор: linuxoid 19.5.2014, 12:27
Оки, спасибо, попробую! Как приеду домой (offtop: я сейчас в командровке, за границей), так попробую сделать всё с нуля на домашнем компе!

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)