Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Java EE (J2EE) и Spring > web сервис не запускается для jboss 3.2.3


Автор: _Fishka_ 31.1.2008, 16:30
Есть приложение написанное на java. Оно содержит web сервис. При помощи ant все приложение упаковываем в архив .ear, в который включен .wsr архив(ахив web сервиса). Помещаем в deploy jboss 3.2.3 конфигурация all. Jboss 3.2.3 содержит встроенную библиотеку axis.jar, которая предназначена для поддержки web сервисов. Проблема в следующем: при попытке с клиента обратиться к нашему web сервису, возникает ошибка:
ERROR [Engine] StandardWrapperValve[JBossAxisServlet]: Servlet.service() for servlet JBossAxisServlet threw exception
javax.servlet.ServletException: Servlet execution threw an exception
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFil terChain.java:269)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain .java:193)
Мне не понятно почему?

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)