| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Java EE (J2EE) и Spring > помогите настроить tomcat |
| Автор: Kratom 3.5.2009, 17:09 | ||
Здрасте, установил Apache Tomcat. удалил из папки ROOT все доки, кидаю туда свой index2.jsp
Захожу на эту страницу и вот такие ошибки HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception org.apache.jasper.JasperException: org.apache.jasper.JasperException: Unable to load class for JSP org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:156) org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) root cause org.apache.jasper.JasperException: Unable to load class for JSP org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:620) org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:144) org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) root cause java.lang.ClassNotFoundException: org.apache.jsp.index2_jsp java.net.URLClassLoader$1.run(Unknown Source) java.security.AccessController.doPrivileged(Native Method) java.net.URLClassLoader.findClass(Unknown Source) org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:134) org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:66) org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:618) org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:144) org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs. что не настроено? И как вообще настроить хосты |
| Автор: Samotnik 4.5.2009, 08:22 |
а в папку webapps уже не модно подлаживать сервлеты ? |
| Автор: _and 4.5.2009, 08:36 | ||
| минимум что должно лежать в ппке webapps - директория с твоим веб приложением в эту директорию положи файл index2.jsp и создай еще одну папку WEB-INF в ней должен быть файлик web.xml со следующим содержанием
должно заработать |
| Автор: Kratom 12.5.2009, 14:25 |
| сделал, как _and сказал, могу заходить на свою страницу по адресу localhost:8080/test , но ошибки теже самые HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception org.apache.jasper.JasperException: Unable to compile class for JSP: An error occurred at line: 2 in the jsp file: /index.jsp Syntax error on tokens, delete these tokens 1: <%@ page import="java.util.*" %> 2: <%! 3: В В В long loadTime= System.currentTimeMillis(); 4: В В В Date loadDate = new Date(); 5: В В В int hitCount = 0; An error occurred at line: 2 in the jsp file: /index.jsp Syntax error on tokens, delete these tokens 1: <%@ page import="java.util.*" %> 2: <%! 3: В В В long loadTime= System.currentTimeMillis(); 4: В В В Date loadDate = new Date(); 5: В В В int hitCount = 0; An error occurred at line: 2 in the jsp file: /index.jsp Syntax error on tokens, delete these tokens 1: <%@ page import="java.util.*" %> 2: <%! 3: В В В long loadTime= System.currentTimeMillis(); 4: В В В Date loadDate = new Date(); 5: В В В int hitCount = 0; An error occurred at line: 17 in the jsp file: /index.jsp Â.out cannot be resolved to a type 14: <H3>Page has been accessed <%= ++hitCount %> 15: times since <%= loadDate %></H3> 16: <% 17: В В System.out.println("Goodbye"); 18: В В out.println("Cheerio"); 19: %> 20: An error occurred at line: 17 in the jsp file: /index.jsp Syntax error on tokens, delete these tokens 14: <H3>Page has been accessed <%= ++hitCount %> 15: times since <%= loadDate %></H3> 16: <% 17: В В System.out.println("Goodbye"); 18: В В out.println("Cheerio"); 19: %> 20: An error occurred at line: 18 in the jsp file: /index.jsp  cannot be resolved 15: times since <%= loadDate %></H3> 16: <% 17: В В System.out.println("Goodbye"); 18: В В out.println("Cheerio"); 19: %> 20: 21: </body></html> An error occurred at line: 18 in the jsp file: /index.jsp Syntax error on tokens, delete these tokens 15: times since <%= loadDate %></H3> 16: <% 17: В В System.out.println("Goodbye"); 18: В В out.println("Cheerio"); 19: %> 20: 21: </body></html> Stacktrace: org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:92) org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330) org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:423) org.apache.jasper.compiler.Compiler.compile(Compiler.java:317) org.apache.jasper.compiler.Compiler.compile(Compiler.java:295) org.apache.jasper.compiler.Compiler.compile(Compiler.java:282) org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:586) org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317) org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs. Apache Tomcat/6.0.18 несколько раз если нажать на кнопку обновить, то появляется другая ошибка HTTP Status 500 - type Exception report message description The server encountered an internal error () that prevented it from fulfilling this request. exception org.apache.jasper.JasperException: org.apache.jasper.JasperException: Unable to load class for JSP org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:156) org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) root cause org.apache.jasper.JasperException: Unable to load class for JSP org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:620) org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:144) org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) root cause java.lang.ClassNotFoundException: org.apache.jsp.index_jsp java.net.URLClassLoader$1.run(Unknown Source) java.security.AccessController.doPrivileged(Native Method) java.net.URLClassLoader.findClass(Unknown Source) org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:134) org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:66) org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:618) org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:144) org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) javax.servlet.http.HttpServlet.service(HttpServlet.java:717) note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs. Apache Tomcat/6.0.18 и если так щелкать долго по кнопке обновить то та, то другая ошибка появляется. На xп свой ставил только такое jdk jdk-6u12-windows-i586-p.exe при установке пишет, что это Java SE SDK. какую jkd для EE ставить |
| Автор: _and 12.5.2009, 14:59 |
| кинь полностью страничку jsp посмотрим видимо кривые директивы на страничке есть или не закрытые директивы |
| Автор: Kratom 12.5.2009, 15:31 | ||
|
| Автор: Kratom 13.5.2009, 15:17 |
| спасибо, заработало а то я в дримвьювер код копировал а он эти знаки не отображал а вообще jsp по идеи на серверной jvm должны выполняться или нет? а то у меня jdk se'шная стоить, а сервлеты там разные это ж вроде EE |
| Автор: Samotnik 13.5.2009, 16:42 | ||
при запуске жсп преобразуются в сервлеты.
все нормально, EE это Sun Server он тебе не нужен |