| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Администрирование Web серверов и Web служб > Странности в новом Апатче |
| Автор: Ak47black 17.6.2006, 00:30 | ||
| Доброе время суток. Сталкнулся с такой интересной проблеммой. При подключении php к apache apache_2.2.2-win32-x86-no_ssl.msi при помоши
При запуске сервера выдается ошибка что модуть неможет быть найден. Уже пробовал и проверял всё что можно но всеровно тоже самое. НО с с такими-же самыми настройка в дрогой версии apache_2.0.58-win32-x86-no_ssl.msi все проходит гладко, некаких ошибок невыдается и все работает и работало и видимо будет работать на ура. Даж без понятий по этому поводу. По наслышке слышал что некоторые нерекомендуют устанавливать новые версии. Что тут может может я незнаю особенности новой версии или в новой верси дапушена грубая ошибка. И как новая версия работает у других. |
| Автор: Sun 17.6.2006, 08:48 |
| Есть подозрение что процесс апача не имеет доступа к c:/www/php/php5apache2.dll. Проверь из под какого юзера запущен Апач и имеет ли этот юзер доступ на чтение. Кроме того посмотри в логах Апача на предмет ошибки и в System Events логе. |
| Автор: Mal Hack 17.6.2006, 11:29 |
| php5ts.dll в Apache2/bin скопировал? |
| Автор: Ak47black 17.6.2006, 13:14 | ||||
Скопировал ,только непомогает. В event Vievere следушая ошибка
Хотя файл сушествует и путь правильно указан. Запушен из под текушего юзера и юзер имеет полный доступ. Самое интересное что в предыдуший версии все шло нормально |
| Автор: Ak47black 17.6.2006, 19:43 | ||||||||
Я конешно неособо разбираюсь в revers'e но по моему он успешно находит. А в ивентах
Прям миcтика какаета. Мож я гдето неправ ? |
| Автор: Sun 19.6.2006, 10:12 |
Значит эта dll требует еще какой-то дополнительной dll которой нет у тебя на машине. Можно посмотреть секцию импорта в php5apache2.dll, например через dumpbin, и проверить все ли dll у тебя есть и лежат ли они в системных дирах. |
| Автор: Ortega 22.6.2006, 01:04 | ||||||
| Столкнулся с похожей проблемой. http://php.net/manual/ru/install.windows.apache2.php прочитал:
Пойдя по указанной ссылке, нашел http://www.apachelounge.com/download/mods/php5apache2.dll-php5.1.x.zip. Однако заставить его работать не получилось поскольку в инструкции к установке этой dll-ки написано следующее:
Выполнить 3й шаг в данный момент не представляется возможным, поскольку та тварь, которую по этой ссылке закачиваешь, требует XP SP2, а у меня первый пак. А без третьего шага при выполнении второго апач отказывается запускаться со словами
А если выполнять только шаг первый, никакого эффекта нет. Ради спортивного интереса собираюсь поставить 2й сервис пак и таки попытаться заставить все это работать. Но это будет позже, поскольку Apache именно 2.2 версии мне не критичен, поживу и с 2.0 Ak47black, попробуй и сообщи о результатах. |
| Автор: Ortega 22.6.2006, 02:20 | ||||||
| В поисках истины я забрел http://www.softtime.ru/info/articlephp.php?id_article=95. Автор статьи справедливо замечает, что
Он предлагает
и делится уже скачанной библиотекой
Однако предложенная им библиотека на моем апаче (apache_2.2.2-win32-x86-no_ssl) пахать не захотела. Пришлось качать. Последую примеру автора статьи и поделюсь библиотечкой. |
| Автор: Ak47black 24.6.2006, 17:07 |
| У меня сразу после установки всего этого незаработало, но потом когда комп перезагрузил все пошло. У меня SP2. |
| Автор: GSMD 26.6.2006, 11:17 |
| Я бы посоветовал все-таки поднять LAMP (хотя бы под VMware), либо, при тотальной невозможности, использовать http://www.denwer.ru или http://apache2triad.net/. |
| Автор: levkin 28.6.2006, 11:53 |
| Спасибо ОГРОМНОЕ ребята за подсказку! Нереально выручили! |
| Автор: malor 27.8.2007, 15:06 | ||||||||
Строки из файла Readme First.txt (архив php5apache2.dll-php5.1.x.zip, скачанный с http://www.apachelounge.com/download/ )
У меня при запуске такое сообщение:
В папке C:/WebServers/usr/local/php5/ лежит файл php5apache2.dll весом 36 927, т.е. тот видимо, что и Ortega предлагает скачать. Что делать? Делал как сказано в инструкции на http://forum.dklab.ru/php/book/UstanovkaApache2058Php514IMysql5022-Podrobno.html :
После того как я набираю в адресной строке localhost/test.php у меня вместо "таблицы с различными параметрами" появляется текст:
WinXP_sp2, apache_2.2.4-win32-x86-no_ssl.msi, php-5.2.1-Win32.zip |
| Автор: sergeysk 1.6.2008, 18:00 |
| I have Windows XP SP2 Копию php5apache2.dll and php5ts.dll, php.ini положил в windows/system32 directory in httpd.conf я добавил: LoadModule php5_module "c:/php/php5apache2.dll" ScriptAlias /php/ "c:/php/" AddType application/x-httpd-php .html .phtml AddType application/x-httpd-php .php4 AddType application/x-httpd-php .php DirectoryIndex index.html index.html.var index.php Когда запускаю Апаче вижу ошибку: httpd.exe: Syntak error on line 118 of C:/Apache2/conf/httpd.conf: Cannot load C://php/php5apache2.dll into server: The specified module could not be found. Я сменил LoadModule php5_module "c:/php/php5apache2.dll" на LoadModule php5_module "c:/php/php5apache2_2.dll" это работает даже без php5apache2_2.dll_, которую я dowloaded. Когда я делитал php5apache2_2.dll_ ничего не изменилось |