| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Администрирование Web серверов и Web служб > Не могу корректно настроить сервер |
| Автор: Icaros 12.7.2006, 18:46 |
| Установил Апач 2.2.2 с помощью инсталлера. (d:/server/bin/apache) Скопировал файлы из архива php в папку (d:/server/bin/php), php.ini в каталог windows В файле httpd.conf добавил в конце строки: ScriptAlias /php/ "D:/server/bin/php/" AddType application/x-httpd-php .php Action application/x-httpd-php "/php/php.exe" В файле php.ini исправил: doc_root = "D:\server\bin\apache\htdocs" extension_dir = "D:\server\bin\php\extensions" В результате при попытке вызвать *.php выводит error 403 (You don't have permission to access /php/php.exe/index.php on this server.) В файле error.log: [Wed Jul 12 19:47:38 2006] [error] [client 127.0.0.1] client denied by server configuration: D:/server/bin/php/php.exe Граждане, помогите. 3-ий день "прыгаю" с серваком... |
| Автор: 2man 13.7.2006, 04:21 |
| http://forum.vingrad.ru/index.php?showtopic=52881 |
| Автор: Icaros 13.7.2006, 10:16 |
| 2man, я не подключал никаких модулей. Мне не понятно. Однако, с Апачей версии 1.х.х все прошло удачно. В чем причина с Апачей 2 я так и не понимаю. А за ссылку все равно спасибо. |
| Автор: Kuber 13.7.2006, 17:08 | ||
Попробуй РНР как модуль подключить:
|
| Автор: Icaros 16.7.2006, 16:11 |
| Я нашел выход из ситуации. #<Directory /> # Options FollowSymLinks # AllowOverride None # Order deny,allow # Deny from all # Satisfy all #</Directory> ... и сервер ожил. Господа, может кто даст внятное разъяснение сему случаю ? (напомню: стоит Виндоз ХР СП2, Апача 2, ПХП 5) |
| Автор: DENNN 17.7.2006, 23:43 |
Внятное разъяснение находится в документации к апачу (директивы конфигурационного файла). Полная нирвана наступит после внимательного изучения директив в этих семи строках. Да прибудет с тобой сила, юный падаван. |
| Автор: kaa 5.10.2006, 21:16 |
| [ФЛУД] DENNN, Самое противное что у мя такая же бодяга... Самое странное что для 2.0.43 ничего комментировать ненадо было! [/ФЛУД] |
| Автор: DENNN 6.10.2006, 09:29 | ||
Самое странное из твоих слов получается, что директиву
комментировать не потребовалось. Неужели так сложно ПРОСТО ОТКРЫТЬ ДОКУМЕНТАЦИЮ и прочитать ЧТО ОЗНАЧАЮТ эти ДИРЕКТИВЫ ? |