Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > Ошибка в логах и пустая страница в отображении


Автор: Ace Wentura 19.3.2009, 16:56
Иногда (непонятно по какой причине и от чего зависит) страница не отображается. При этом простая перезагрузка страницы (релоад) может привести к нормальной работе, а может и не привести.
В логах примерно такой текст:
Код

[Thu Mar 19 16:18:42 2009] [error] [client ...] PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0, referer: ...
[Thu Mar 19 16:18:42 2009] [error] [client ...] PHP Warning:  Unknown: Failed opening 'ПУТЬ/ФАЙЛ' for inclusion (include_path='.:') in Unknown on line 0, referer: ...

Что это и как с этим бороться?
Рестарт сервера не помогает никак.

PS: связка Apache+PHP

Автор: DSsupport 19.3.2009, 19:09
Есть несколько наиболее вероятных вариантов:

1) Неправильный путь к файлу(возможно в полном пути указан пробел или не английские символы). Тут необходим полный вывод ошибки, без замены 'ПУТЬ/ФАЙЛ'.
2) Возможно, пристроен некий mod_rewrite, к-рый все запросы переадресовывает на broken_include_script.php, к-рый что-то там инициализирует (с ошибками), а затем уже включает file.php
3) Неправильно собран php. Какая операционная система? как устанавливался php.

Автор: Ace Wentura 19.3.2009, 22:50
Такое ощущение, что это третий вариант.
1 нереален вследствие того, что нет пробелов в пути. Да и происходит это не каждый раз. Можно просто нажать релоад и не получить ничего, а потом нажать ещё раз и получить нормальное отображение. Раз на раз не приходится
2 нереален из-за того, что происходит это на нескольких сайтах, один из которых по модреврайту не работает (там только аутентификация через апач), второй вообще без htaccess, а остальные с мод-реврайтом. Так что грешить на это наверное не стоит
3. Стоит FreeBSD+php5. НО ставили панель ISPManager. И что там с ней происходило, что она с собой принесла - никто не знает. При этом реально стала заметна проблема только в последние несколько дней, хотя сервер работает уже порядка двух лет. Может быть обновление (вроде как какие-то ставятся автоматом) при установке сделало какую-нибудь гадость?

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)