Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > Не запускается phpMyAdmin


Автор: Voldemar2004 31.7.2011, 19:22
Выдаёт такую ошибку

user posted image

Файл config.inc.php сохранен в htdocs\pma: 

Код

<?php
    $i = 0;
    $i++;
    
    $cfg['Servers'][$i]['host'] = 'localhost';    
    $cfg['Servers'][$i]['extension'] = 'mysql';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['compress'] = false;
    $cfg['Servers'][$i]['auth_type'] = 'config';
    $cfg['Servers'][$i]['user'] = 'root';
    $cfg['Servers'][$i]['password'] = '123456';
?>


Причем Apache, PHP 5.3, MySQL были нормально установлены.

При вызове файла с кодом:

Код
<?php 

  if ($m_db=mysql_connect("localhost", "root", "123456")) 
  { 
  echo "<H2>Содержимое базы данных \"mysql\"</H2>"; 
   if($m_res = mysql_list_tables("mysql")) 
   {  
    while ($m_row = mysql_fetch_row($m_res)) { 
     echo "Таблица: $m_row[0]<br>"; 
    } 
   } 
   else { 
    echo "Ошибка " . mysql_errno() . " " . mysql_error(); 
   } 
  } 
  else { 
   echo "Ошибка" . mysql_errno() . " " . mysql_error(); 
  } 
   
 ?>


Выдаёт сообщение:

Цитата
Содержимое базы данных "mysql" 

 Deprecated: Function mysql_list_tables() is deprecated in C:\Apache\htdocs\test.php on line 6 
 Таблица: columns_priv 
 Таблица: db 
 Таблица: event 
 Таблица: func 
 Таблица: general_log 
 Таблица: help_category 
 Таблица: help_keyword 
 Таблица: help_relation 
 Таблица: help_topic 
 Таблица: host 
 Таблица: ndb_binlog_index 
 Таблица: plugin 
 Таблица: proc 
 Таблица: procs_priv 
 Таблица: proxies_priv 
 Таблица: servers 
 Таблица: slow_log 
 Таблица: tables_priv 
 Таблица: time_zone 
 Таблица: time_zone_leap_second 
 Таблица: time_zone_name 
 Таблица: time_zone_transition 
 Таблица: time_zone_transition_type 
 Таблица: user


Т.е. MySQL был нормально установлен.

Автор: GZep 31.7.2011, 22:42
в сообщении phpMyAdmin написано же, что надо смотреть лог файл.

phpMyAdmin пытается открыть сессию но не может так как заголовки были отправлены клиенту из-за ошибки.

Автор: Voldemar2004 6.8.2011, 22:36
В файле php.ini директива

Код

session.save_path


Указывает на

Код

session.save_path = "c:/php5/tmp"


Создал папку tmp - всё заработало.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)