Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > Кто-нибудь устанавливал Apache


Автор: vio 26.1.2005, 10:32
Я устанавливаю Апач, исправляю файл httpd.conf, но у меня все равно не меняется директория для моих сайтов. Все так и остается, как и по умолчанию.

Автор: rMaveric 26.1.2005, 11:57
А что на что хоть исправляешь?

Автор: malor 30.7.2007, 20:07
В трее - левой кнопкой мыши, далее Apache2->Start, выдает: 
Error 
--------------------------- 
The requested operation has failed! 


Куда копать? 

Использую книгу "PHP 5 В подлиннике" Котеров&Костарев, 2006,BHV. 
WinXP_sp2, apache_2.0.59-win32-x86-openssl-0.9.7j.msi

Автор: belousov 30.7.2007, 20:34
Цитата

The requested operation has failed!


когда он так пишетпричин может быть очень много, если ты менял директорию с сайтом и допустил ошибку в синтаксисе, он мог выдать такую ошибку

Автор: comtat 30.7.2007, 21:26
Полностью согласен с belousov, вариантом там масса ..
В директорию, на которую ты переписал, положи файлик index.php
с содержимым типа 
Код
<?
phpinfo();
?>

Тогда если инфа оттобразится то дело действительно в синтаксисе  smile 
И предоставь для разбора свой конф

Автор: belousov 30.7.2007, 21:32
comtat, а если у него сервак не стартует то как он страницу то увидит

Добавлено через 3 минуты и 15 секунд
vio, а у тебя если не меняется директория то скорей всего не там исправляешь

Автор: comtat 30.7.2007, 21:44
1) Под Linux, если Apache не может стартануть то он выводит строку, в которой ошибка
либо можно посмотреть в запущенных процессах
2) В Винде вываливается message, что служба не может запущена

вот и все ..
если такое не произошло то апатч запущен
притом это можно запросто проверить

Автор: belousov 30.7.2007, 21:47
comtat, ну да логично, ладно бум ждать чего ответят, да у него вроде и не линукс...

Автор: marykone 31.7.2007, 08:21
vio, перезапусти апач
malor, для начала удали апач и все прилогающееся и поставь заново 
вбей http://localhost/(везде при установке имя сервера и еще что то пиши локалхост)

должна запуститься страничка  

скопируй файл httpd.conf(для подстраховки) в отдаленное место и редактируй который в директории апач смотри и радуйся 

http://www.web.compdoc.ru/articles/apache_httpdconf.php

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)