Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > *NIX системы: Общие вопросы > php5 & apache 2.0.49


Автор: Chuck 19.8.2004, 18:22
Приветствую!!!
Поставил САБЖ
и вот такое вылезает
Last login: Thu Aug 19 20:06:25 2004 from 192.168.1.2
[root@chuck root]# /usr/local/apache2/bin/apachectl start
Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: compress
[root@chuck root]#
А вот строка 232 LoadModule php5_module modules/libphp5.so
Почему??? Может кто сталкивался???

Автор: Secandr 20.8.2004, 08:16
Попробуй ставить апас 1.3, вместо 2. Второй с пхп криво работает.

Автор: DENNN 20.8.2004, 11:04
Цитата
Попробуй ставить апас 1.3, вместо 2. Второй с пхп криво работает.

второй еще и дырявый - в неделю по новой дыре находят

Автор: Chuck 20.8.2004, 11:41
Спасибо! Качаю!!!
НО все таки интерестно, почему у друга встал нормально, а у меня компрессед!???

Автор: Chuck 20.8.2004, 13:34
Скачал апаче 1.3.31
Поставил!!!
Результат тот же (((


[root@chuck root]# /usr/local/apache/bin/apachectl start
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache/libexec/libphp5.so: undefined symbol: compress
/usr/local/apache/bin/apachectl start: httpd could not be started

Автор: DENNN 20.8.2004, 13:37
ну ведь он сам ясно же написал
Цитата
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:


Цитата
Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache/libexec/libphp5.so: undefined symbol: compress

заходи на сайт php и смотри как надо правильно компилить.

Автор: Chuck 21.8.2004, 13:43
проблема найдена
нужно было собирать
Код
./configure ... --with-gzip --...

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)