| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Oracle > Logminer не возвращает значения |
| Автор: tvik 21.8.2007, 14:30 | ||||||
| Всем, привет!!! Может кто пользовался LogMiner и сталкивался с такой проблемой: делаю следующее
делаю запрос типа
все работает а вот в 10 не прокатывает такое, даже запрос select * from v$logmnr_contents where table_name = 'F' and operation='UPDATE; обновление сделано недавно, может строки еще не записалить в журнал, а висят где-то в буфере?? как записать все содержимое в буфер?? или в чем причина?? записи обновлены,commit сделан база Oracle 10g, noarchivemode. после различных попыток-запросов вообще вылетает ошибка
будет очень приятно почитать комментарии специалистов |
| Автор: Sqlninja 21.8.2007, 14:34 |
| Если commit issued, то журналы записаны, однозначно. |
| Автор: tvik 22.8.2007, 05:11 |
| update в Developer был сделан, нажатием на кнопку "commit". , а что значит commit issued не знаю. |
| Автор: tvik 22.8.2007, 06:27 | ||
| всем, доброе утро!! утро началось ))) логмайнер был остановле dbms_logmnr.end.logmnr.... поновой его запуск - на 9-ке все отработало нормально, на 10g опять не увидел update а последовательность следующих запросов привела к той же ошибке
и потом на любой запрос с подобными условиями возникает ошибка (( затем был произведен update и delete из Developer (из sql window и сommand window на всякий случай). эти же запросы, все работает, все находит, кроме вчерашних апдейтов ((( Изменения-то в таблице есть!!!, а записей об изменениях нет!!!(( Где они??? непонятно ((?? и ошибка после нового update изчезла (тьфу-тьфу ))) |
| Автор: Sqlninja 27.8.2007, 17:15 |
| 600-я ошибка - это ошибка ядра, и скорее всего надо накатить какой нить патч, или искать ответ на металинке. Полная версия сервера какая? |