Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Oracle > Перенос БД Oracle 9.2 на другую машину в лок. сети


Автор: Lamya 19.4.2010, 11:11
Добрый день.

Возможно, кто-то сталкивался с проблемой, описанной ниже.

Необходимо перенести БД на другую машину в той же локальной сети. Версия Oracle 9.2.0.1, на обеих машинах Win 2003 Server. СУБД установлена, перенос осуществлен физическим копированием файлов (по этой статье http://www.sql.ru/forum/actualthread.aspx?tid=240418). Служба создана, сеть настроена, сиды совпадают.

Проблема в следующем: после перезапуска системы не стартует процесс oracle.exe. При попытке соединения выдает ошибку Oracle not available ORA-01034. После ручного startup все работает, но процесса oracle.exe в диспетчере задач все равно нет. На исходной машине процесс запускается автоматически и ошибки нет. Как устранить ошибку копии?

Автор: ToshaCh 19.4.2010, 11:25
Посмотрите настройки созданной службы в винде. Там, по всей видимости, не поставлена опция автостарта (не помню как оно в винде точно называется).

Автор: Lamya 19.4.2010, 11:32
Служба находится в автоматическом режиме со строкой d:\oracle\ora92\bin\ORACLE.EXE <сид базы>. Файл alert.log ошибок при запуске не содержит. До ручного запуска базы в него вообще ничего не пишется.

Автор: Lamya 20.4.2010, 09:38
Неожиданно нашлось решение проблемы: автостарт службы Windows был выставлен, а oracle - нет. Нужно проверить в реестре, чтобы параметр ORA_<sid>_AUTOSTART был true и настроить автозапуск через Oracle Administration Assistant: ... -> Databases -> <sid> -> Startup/Stutdown Options -> Start up instance when service is started.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)