Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Oracle > ora-01219


Автор: р 13.1.2006, 11:47
Пытаюсь в DBA Studio зайти куда-либо. Выдает ошибку ora-01219. Что делать? Что надо исправить?

Автор: batigoal 13.1.2006, 11:58
Цитата

ORA-01219 database not open: queries allowed on fixed tables/views only

    Cause: A query was issued against an object not recognized as a fixed table or fixed view before the database has been opened.

    Action: Re-phrase the query to include only fixed objects, or open the database.


Автор: LSD 13.1.2006, 17:58
Надо стартовать базу:
Код
connect sys/<sys_password>@<db_name> as sysdba
startup

Автор: batigoal 13.1.2006, 21:08
Цитата(LSD @ 13.1.2006, 18:58 Найти цитируемый пост)

as sysdba

Так определется роль? А по умолчанию просто подставляется normal, видимо?

Автор: LSD 13.1.2006, 22:15
Цитата(Lamer George @ 13.1.2006, 21:08 Найти цитируемый пост)
Так определется роль? А по умолчанию просто подставляется normal, видимо?

Это не совсем роль, это системная привилегия, дает право на соединение с остановленным экземпляром, права на запуск/останов экземпляра, и заодно роль DBA. Логины и пароли пользователей, которым даны эти привилегии, храняться в файле паролей (если таковой создан), чтобы позволить соединяться с остановленным экземпляром.
Normal означает, что ни привилегия SYSDBA, ни SYSOPER не используются, обычно коннекты так и идут.

Автор: batigoal 13.1.2006, 22:44
Цитата(LSD @ 13.1.2006, 23:15 Найти цитируемый пост)

Normal означает, что ни привилегия SYSDBA, ни SYSOPER не используются, обычно коннекты так и идут.

Я имел в виду - если мы вообще опустим as, соединение будет установлено, как normal? Или это синтаксическая ошибка?

Автор: LSD 13.1.2006, 22:48
Цитата(Lamer George @ 13.1.2006, 22:44 Найти цитируемый пост)
Я имел в виду - если мы вообще опустим as, соединение будет установлено, как normal?

Да, если не указанно то соединение идет как normal.

Автор: Guest 14.1.2006, 11:16
Остановила и стартанула базу. Выдал такие ошибки:
ORA-01157: cannot identify/lock data file 10 - see DBWR trace file
ORA-01110: data file 10: 'D:\ORACLE\ORADATA\BAAN\BAANINDX.DBF'

Автор: LSD 14.1.2006, 18:39
Oracle не может открыть файл D:\ORACLE\ORADATA\BAAN\BAANINDX.DBF, проверь что файл находится на месте и его никто не держит.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)