Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > MySQL > MySQL Control Center не подключается


Автор: Firebird 31.1.2008, 07:56
  Привет!

  Есть MySQL версии 5.0.45, установлен на сервере. Клиенты не могут соединиться, выдается ошибка

ERROR 2003: Can not connect to MySQL Server on 'IP' (10060)

Автор: admsasha 31.1.2008, 08:11
причин много...
1. включен skip-networking 
2. закрыт firewall`ом
3. Сервер не запущен  smile

и т.д.

Автор: Firebird 31.1.2008, 09:12
  Вообщем помоему брандмауэр блокировал. Отключил брандмауэр на сервере и на клиентских машинах, соединение выполнилось. Да есть еще один момент. По умолчанию на сервере нет пользователя, для которого разрешен доступ не с локального, а с удаленного компьютера. По этому нужно его создать. Если соединение с сервером выполнилось, но нет доступа для пользователя, то выйдет уже друга ошибка:

  Access denied for user...

Чтобы создать пользователя для доступа с любого удаленного компьютера, необходимо при создании или редактировании пользователя указать парметр 
  host = %

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)