| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > MySQL > Как настроить MySQL... |
| Автор: Bangladesh 8.11.2004, 03:54 |
| я юзаю MyServer 3.2.1 и вот что-то никак не пойму как установить МуСКУЛ. Пробывал настраивать по книге САМОУЧИТЕЛЬ PHP4, но он пишет (цитирую): \ Не могу соединиться с базой test! Can't connect to MySQL server on 'localhost' (10061) @echo off "C:\Program Files\MySQL\bin\mysqld" start /m "C:\Program Files\Apache Group\Apache\Apache" Буду очень благодарен за ответы, обязательно поставлю + С уважение, Гёз. |
| Автор: sergejzr 8.11.2004, 04:07 |
| Can't connect to MySQL server on 'localhost' (10061) Что то странно 10061. Это не Порт? У мускула по умолчанию: 3306 Мой совет, заинсталлирутей http://www.mysql.com/products/mysqlcc/ И в нём пробуйте соеденится. В Мускуле всегда есть база test. Если это не получится, тогда мускул надо винить |
| Автор: Bangladesh 9.11.2004, 01:07 |
| а как его вообще под локалхост поставить? непонимаю, где и как его менять. я еще не опытный в работе в мускул. а сейчас он необходим. |
| Автор: sergejzr 9.11.2004, 02:00 |
| Мускул на Вашем компе? тогда он на локалхосте C:\mysql\bin\winmysqladmin.exe А потом с помощью http://www.mysql.com/products/mysqlcc/ попробуйте соеденится с ней |
| Автор: Ignat 9.11.2004, 10:15 |
| I, GyoZ, не рекомендую запускать mysqld из bat-файла, т.к. пакетный файл не выполняет последующую комманду пока не дождетсязавершения предыдущей, а mysqld не завершается при загрузке. Попробуйте сначала запустить его "вручную". |
| Автор: Bangladesh 10.11.2004, 01:40 |
| Значит вот что делаю: 1. Запускаю MyServer (Apache и PHP) - тут проблем нет. 2. Запускаю файл winmysqladmin.exe - появляется светофор на панельке задач 3. Запускаю файл mysqld-nt.exe пишет то - же самое... я смотрел лог запуска (start check) там написано: server is running........ no может в этом проблема? кстати еще в сообщениях о ошибках там все Normal написано, ошибок не нашел. my.ini вроде тоже нормально настроен. а вот подключаться не могу |
| Автор: Bangladesh 14.11.2004, 01:17 |
| ну поможет кто-нибудь!!?? срочно надо |
| Автор: sergejzr 14.11.2004, 03:49 |
| mysqld-nt.exe зачем запускать? Светофор горит, значит всё ОК. Осталось только соедениться. Вы пробовали mysqlcc? Ignat ОК, насчёт 10061, понял, убрал |
| Автор: Ignat 15.11.2004, 00:23 |
| I, GyoZ, попробуйте подсоединиться телнетом из коммандной строки: telnet localhost 3306 Что вы видите? Ошибка или успешный коннект? |
| Автор: Bangladesh 15.11.2004, 02:18 |
| что такое телнет??? и как им воспользоваться? |
| Автор: sergejzr 15.11.2004, 02:21 |
| Меню: Старт->Выполнить В окошке написать для WIN98 command.com, для XP cmd Откроется дос-окно, туда и задать строку: telnet localhost 3306 ПС: Хотя, если светофор горит, то должно быть всё ОК.. |
| Автор: Ignat 15.11.2004, 10:08 | ||
По идее должно... Но может правда порт не такой. Еще трабла может быть в фаерволе. |
| Автор: Bangladesh 16.11.2004, 02:04 |
| светофор горит на красном а не на зеленом. гы... а через 3306 по телнету не подрубается, а вот через 80 подрубается, там типа нифига не пишется. жмешь ентер и какой-то бред с тегами HTML , что делать??? |
| Автор: sergejzr 16.11.2004, 02:07 |
| На красном значит настройки не так... |
| Автор: Ignat 16.11.2004, 10:21 |
| Ну дык ясен пень, по 80 подключится - это апач отвечает. А мускуль ответит только на том порту, на котором настроен. Тогда будем шаманить Попробуйте переместить временно файл my.ini из виндовой директории и запускать не mysqld-nt, а mysqld-max или просто mysqld. Какая у Вас версия винды? |
| Автор: Bangladesh 17.11.2004, 02:09 |
| Так вообщем у меня WinXP вот что в файле my.ini [WinMySQLAdmin] Server=C:/myserver/mysql/bin/mysqld.exe чава делать? может надо port=%порт% поставить??? подскажите? еще раз повторюсь: в логе с ошибками пишет, что типо все комплит и все ОК... |
| Автор: Ignat 17.11.2004, 09:55 |
| Это всё что есть в файле my.ini? Там вообще нет секции [mysqld]? Тогда попробуйте в файле my.ini: [mysqld] port=3306 PS А то что я в предыдущем поте написал, пробовали? |
| Автор: Bangladesh 18.11.2004, 03:20 |
| да я все попробывал - нифига не делается... и с добавление в май.ини тоже ничего слушайте, а если MySQL поставить отдельно он будет работать с майсервером? |
| Автор: Secandr 18.11.2004, 09:15 |
| I, GyoZ Лучше всё отдельно ставить |
| Автор: Bangladesh 19.11.2004, 02:33 |
| да какя разница... поставил его отдельно, пробывал запускать через все ексе, нифига. запускаешь - горит зеленый, секунд 5 и красный... что делать? люди хелп? порты все прописал вроде, май.ини нормальный... а не хочет пахать... |
| Автор: Ignat 19.11.2004, 10:44 |
| Зпости лог. Если горит зеленый, а потом красный, не может быть, чтоб в логах ничего не осталось. |
| Автор: Bangladesh 20.11.2004, 02:20 |
| вообщем вот из папки include errmsg.txt /* Copyright © 2000 MySQL AB This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA */ /* Error messages for MySQL clients */ /* (Error messages for the daemon are in share/language/errmsg.sys) */ #ifdef __cplusplus extern "C" { #endif void init_client_errs(void); extern const char *client_errors[]; /* Error messages */ #ifdef __cplusplus } #endif #define CR_MIN_ERROR 2000 /* For easier client code */ #define CR_MAX_ERROR 2999 #if defined(OS2) && defined(MYSQL_SERVER) #define CER(X) client_errors[(X)-CR_MIN_ERROR] #elif !defined(ER) #define ER(X) client_errors[(X)-CR_MIN_ERROR] #endif #define CLIENT_ERRMAP 2 /* Errormap used by my_error() */ #define CR_UNKNOWN_ERROR 2000 #define CR_SOCKET_CREATE_ERROR 2001 #define CR_CONNECTION_ERROR 2002 #define CR_CONN_HOST_ERROR 2003 #define CR_IPSOCK_ERROR 2004 #define CR_UNKNOWN_HOST 2005 #define CR_SERVER_GONE_ERROR 2006 #define CR_VERSION_ERROR 2007 #define CR_OUT_OF_MEMORY 2008 #define CR_WRONG_HOST_INFO 2009 #define CR_LOCALHOST_CONNECTION 2010 #define CR_TCP_CONNECTION 2011 #define CR_SERVER_HANDSHAKE_ERR 2012 #define CR_SERVER_LOST 2013 #define CR_COMMANDS_OUT_OF_SYNC 2014 #define CR_NAMEDPIPE_CONNECTION 2015 #define CR_NAMEDPIPEWAIT_ERROR 2016 #define CR_NAMEDPIPEOPEN_ERROR 2017 #define CR_NAMEDPIPESETSTATE_ERROR 2018 #define CR_CANT_READ_CHARSET 2019 #define CR_NET_PACKET_TOO_LARGE 2020 #define CR_EMBEDDED_CONNECTION 2021 #define CR_PROBE_SLAVE_STATUS 2022 #define CR_PROBE_SLAVE_HOSTS 2023 #define CR_PROBE_SLAVE_CONNECT 2024 #define CR_PROBE_MASTER_CONNECT 2025 #define CR_SSL_CONNECTION_ERROR 2026 #define CR_MALFORMED_PACKET 2027 #define CR_WRONG_LICENSE 2028 /* new 4.1 error codes */ #define CR_NULL_POINTER 2029 #define CR_NO_PREPARE_STMT 2030 #define CR_PARAMS_NOT_BOUND 2031 #define CR_DATA_TRUNCATED 2032 #define CR_NO_PARAMETERS_EXISTS 2033 #define CR_INVALID_PARAMETER_NO 2034 #define CR_INVALID_BUFFER_USE 2035 #define CR_UNSUPPORTED_PARAM_TYPE 2036 #define CR_SHARED_MEMORY_CONNECTION 2037 #define CR_SHARED_MEMORY_CONNECT_REQUEST_ERROR 2038 #define CR_SHARED_MEMORY_CONNECT_ANSWER_ERROR 2039 #define CR_SHARED_MEMORY_CONNECT_FILE_MAP_ERROR 2040 #define CR_SHARED_MEMORY_CONNECT_MAP_ERROR 2041 #define CR_SHARED_MEMORY_FILE_MAP_ERROR 2042 #define CR_SHARED_MEMORY_MAP_ERROR 2043 #define CR_SHARED_MEMORY_EVENT_ERROR 2044 #define CR_SHARED_MEMORY_CONNECT_ABANDONED_ERROR 2045 #define CR_SHARED_MEMORY_CONNECT_SET_ERROR 2046 #define CR_CONN_UNKNOW_PROTOCOL 2047 #define CR_INVALID_CONN_HANDLE 2048 #define CR_SECURE_AUTH 2049 #define CR_FETCH_CANCELED 2050 #define CR_NO_DATA 2051 |
| Автор: Ignat 20.11.2004, 22:42 |
| Хм... Однако. Вы мне привели заголовочный файл. лог-файл находится в папке DATA и имеет расширение .err |
| Автор: Bangladesh 21.11.2004, 02:01 |
| сорри. нуб еще... как ни странно в папке Date имеются папки MySQL и test, так вот, test полностью пустая, а в MySQL много разных файлов. но вот файлов с расширением .err я вообще не нашел (искал внимательно). странно... что делать? |
| Автор: Ignat 21.11.2004, 02:09 | ||
Это собственно папки, где хранятся данные. |
| Автор: Bangladesh 21.11.2004, 04:03 |
| ну я и говорю. я смотрел везде в папке ДАТА, там файлов такого расширения нет вообще |
| Автор: sergejzr 21.11.2004, 04:08 |
| Вот смотрите моя папка мускула: Там 3 базы, логи и еррор-файл |
| Автор: Bangladesh 22.11.2004, 01:56 |
| скажите как вставить картинку я вам покажу... у меня ничего этого нет. только test и mysql и больше никаких файлов. (скрытые включены)... я отдельно устанавливал... ну ладно, я забил на ту которую установил отдельно, посмотрел, что мне пишет майсервер, а там я нашел вайл с еррорами... вот содержание: (будем настраивать этот) MySql: ready for connections 020831 16:10:03 MySql: Normal shutdown 020831 16:10:04 MySql: Forcing close of thread 3 user: 'Gv' 020831 16:10:04 MySql: Shutdown Complete MySql: ready for connections 020831 16:53:46 MySql: Normal shutdown 020831 16:53:46 MySql: Shutdown Complete MySql: ready for connections 020831 17:14:53 MySql: Normal shutdown 020831 17:14:53 MySql: Shutdown Complete MySql: ready for connections 020831 23:08:16 MySql: Normal shutdown 020831 23:08:16 MySql: Shutdown Complete MySql: ready for connections 020901 18:35:41 MySql: Normal shutdown 020901 18:35:41 MySql: Shutdown Complete MySql: ready for connections 020907 7:30:47 MySql: Normal shutdown 020907 7:30:47 MySql: Shutdown Complete |
| Автор: Ignat 22.11.2004, 10:39 |
| Если учесть, что на дворе 2004 год, то этот лог несколько устарел (года на два). |
| Автор: Bangladesh 23.11.2004, 01:04 |
| необращайте внимание, это не важно ... что делать? нужен мускул... |
| Автор: Ignat 23.11.2004, 10:22 |
| Не запуская MyServer, запустить файл mysqld.exe из того дистрибутива, который устанавливался отдельно. Предварительно переместить my.ini из папки windows, чтоб в папке винды его близко не было (это позволит запустить mysql-сервер с настройками по умолчанию). Если есть фаервол, то отключить его нафиг. После запуска mysqld.exe подсоединиться telnet'ом, как описывалось. |
| Автор: Bangladesh 24.11.2004, 03:26 |
| я попытался поэкспериминтировать с мастером настройки ... он, когд начинает завершаюший этап на Start Service останавливается - видимо, что- то с mysqld буду пробывать как вы говорили |
| Автор: Bangladesh 24.11.2004, 03:47 |
| докладываю обстановку: MySQL из Myserver 1. Не хочет запускаться 2. Имеет лог об ошибках 3. Почему то в корневом каталоге нет my.ini 4. Доступны mysqld любого типа. MySQL отдельноустановленный: 1. Не хочет запускаться 2. Не ведет лога об ошибках 3. В корневом каталоге есть my.ini и еще много .ini файлов. 4. Не доступен mysqld-opt 5. При.. так.так.так.... вот вообщем я счас рылся и star service в мастере настоек прошел, после того как я выбрал вместо MySQL MySQL4... попробывал запустить, все равно нифига, но зато установленный отдельно он лог начал писать, вот ошибку выдал: C:\Program Files\MySQL\MySQL Server 4.1\bin\mysqld-nt: ready for connections. Version: '4.1.7-nt' socket: '' port: 3306 Source distribution может что подскажете? Добавлено @ 03:53 заработало !!! ура |
| Автор: Ignat 24.11.2004, 10:13 | ||
Это не ошибка Это сообщение о нормальном запуске. |