| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > PHP: Общие вопросы > настройки php |
| Автор: Zzet 21.9.2009, 15:52 |
| здравствуйте! такая вот проблемка: перенесли сайт на другой хостинг теперь большинство пользовательских функций не работает: добавление записи в бд и т.п. файлы теже структура бд таже. на хостинге говорят В вашем случае настройки надо проверять под ваше приложение Стоят не те настройки. Установить правильные. Проверяю через функцию php_info. пытался в .htaccess написать директивы подобного рода php_value register_globals off как у себя на денвере. не могу понять почему сайт теперь некорректно работает. раньше с такой проблемой не сталкивался. не знаю что конкретно предпринять? поделитесь опытом и советами пожалуйста. Добавлено через 3 минуты и 34 секунды |
| Автор: Simpliest 21.9.2009, 16:14 |
| Брать конкретные сообщения об ошибках и разбираться. Для этого надо включить (если не включено) error_reporting = E_ALL | E_STRICT display_errors = On Если не хотим выводить на экран log_errors = On error_log = "путь к логу" |
| Автор: Ипатьев 21.9.2009, 16:16 |
| конкретно надо разбираться с конкретными функциями и методом отладки находить причину. но это доступно только программисту. юзерам остается только тыкать наугад. непонятно, при чем тут денвер, если речь о хостинге. |
| Автор: Ипатьев 21.9.2009, 16:44 |
| Zzet, судя по всему, вы не программист. Вам надо обратиться к программисту. Если установка register_globals on не решит проблему. |
| Автор: patap 21.9.2009, 16:46 |
| может настройки БД в скрипте? |
| Автор: Simpliest 21.9.2009, 16:48 |
Вы путаете функции приложения и функции PHP. Разбираться надо с последними. Включать указанные директивы нужно в php.ini |
| Автор: Zzet 21.9.2009, 16:48 |
| установка register_globals on была произведена. сайт написал собственноручно. на старом хостинге работало все отлично. код рабочий. Добавлено через 4 минуты и 10 секунд запись категорий в бд в панели управления осуществляется без проблем, так же как и их обновление с удалением. значит дело не в базе как физически добраться до php.ini на хостинге. подскажите, пожалуйста у меня мало опыта в таких делах |
| Автор: Ипатьев 21.9.2009, 16:53 |
| Да какая разница - собственноручно или не собственноручно. Вам сказали - обратитесь к программисту |
| Автор: Zzet 21.9.2009, 16:54 | ||
|
| Автор: Simpliest 21.9.2009, 17:02 |
Вы собираетесь изучать PHP? Если нет, то Ипатьев прав - обратитесь к специалисту. Сэкономите и свое время тоже. Если собираетесь изучать, то придется начать с азов и забыть(на время) про ваше вебприложение. |
| Автор: patap 21.9.2009, 17:03 |
| несоответствие версий пхп...... |
| Автор: Zzet 21.9.2009, 17:12 |
| ответ специалиста-программиста заключался в следующем : Думаю первое надо проеверить каким настройкам не удолетворяет php, которые сконфигурирован на сервере у настройам сайта. Проверьте через функцию php_info. что и было мной сделано в следующем : Просто в .htaccess написать директивы подобного рода php_value register_globals off что и было мной сделано Добавлено через 48 секунд |
| Автор: Ипатьев 21.9.2009, 17:15 | ||
| Это был не специалист. Вас обманули. в РНР нет функции php_info() и программисты не занимаются поиском ошибок методом тыка. Добавлено через 1 минуту и 48 секунд
вы определитесь, пожалуйста какая именно настройка была произведена. большинство сайтов, написанных начинающими программистами по устаревшим учебникам, требуют on |
| Автор: Zzet 21.9.2009, 17:19 |
| мне обратиться больше не к кому. и не факт что не обманут как оказалось. |
| Автор: Ипатьев 21.9.2009, 17:22 |
| Попробуйте научиться программировать самостоятельно. Это не так сложно. Выясняем, каким путем должны пройти данные от капчи в скрипт. и проверяем их на всем пути - где пропали. по этому признаку можно будет найти "другую настройку" или другую причину, ответственную за неработающий скрипт. если отключить проверку капчи, то запись в базу производится? |
| Автор: Zzet 21.9.2009, 17:22 |
| Ипатьев, натолкните на мысль. ато совсем меня все запинали |
| Автор: Simpliest 21.9.2009, 17:22 |
| Мда вы настойчивы. Ну тогда собственно результаты того, что было сделано не озвучите? А именно полный список отличий вывода phpinfo() там где ваш сайт работает и там где он не работает. После того как вы его получите.... поймите бесперспективность этого пути. И начинайте разбираться с конкретными ошибками которые вам выдает php. Добавлено через 1 минуту и 32 секунды например вот такими, как указано в этом топике http://forum.vingrad.ru/forum/topic-273660.html |
| Автор: Ипатьев 21.9.2009, 17:27 | ||
| сначала, точно так же, как и register_globals установить
но это может и не сработать, если хостер не обрабатывает htaccess |
| Автор: Zzet 21.9.2009, 17:43 | ||||
запись в базу осуществляется прекрасно если капчу отключить.
Undefined index: it2 выдает. значит проблемы с register_globals (установлено on).? теперь ошибки выдает такого рода перед вводом данных Добавлено через 1 минуту и 50 секунд запись в базу осуществляется прекрасно если капчу отключить.
Undefined index: it2 выдает. значит проблемы с register_globals (установлено on).? теперь ошибки выдает такого рода перед вводом данных |
| Автор: Simpliest 21.9.2009, 17:50 |
Нет. "Имеет место быть" либо ошибка с возвратом результата или инициализацией массива. Нужно брать номер строки и имя файла из сообщения об ошибке. Идти в этот файл и смотреть ту строку (а так же строки выше нее). Нужно найти откуда у нас берется массив в котором "Undefined index: it2" P.S. Кстати, такой вопрос - а капча чья? Т.е. используется ли своя или сторонний сервис вроде ReCapcha? |
| Автор: Zzet 21.9.2009, 17:55 |
его /**************************************************************************************************** ***************************************************************************************************** ** ** ** Скрипт генерации случайных изображений ** ** Версия: 1.1 ** ** ** ** Автор: Афанасьев Артём ** ** E-mail:triall2002@mail.ru ** ** ICQ:1522817 ** ** Дата: 06.07.2006 ** ** ** ***************************************************************************************************** ****************************************************************************************************/ скачал с сайта кокого-уже не помню Добавлено через 32 секунды простите забыл к код "одеть" |
| Автор: Simpliest 21.9.2009, 18:04 |
Проблемы не в этой капче. Смотрите те строки на которые ссылается сообщение об ошибке. |
| Автор: Zzet 21.9.2009, 20:52 | ||||||
или так нельзя? |
| Автор: Ипатьев 21.9.2009, 21:13 |
а можно чуть развернутее? |
| Автор: Zzet 21.9.2009, 21:26 | ||||||
Добавлено через 3 минуты и 12 секунд продолжение
Добавлено через 4 минуты и 27 секунд продолжение
|
| Автор: Ипатьев 21.9.2009, 21:32 |
| и в каком из этих многочисленных блоков про блокировку сообщения о неверном коде пользователю? |
| Автор: Zzet 21.9.2009, 21:36 | ||||
Добавлено через 31 секунду
|
| Автор: patap 21.9.2009, 21:46 |
| сессии вообще работают нормально? |
| Автор: Zzet 21.9.2009, 22:02 |
как проверить? |
| Автор: Ипатьев 22.9.2009, 02:02 |
| Zzet, и где здесь блокировка сообщения? Откуда вообще взялась идея о том, что ошибка что-то блокирует? написать тестовый скрипт? |
| Автор: patap 22.9.2009, 08:15 | ||||
|
| Автор: Ипатьев 22.9.2009, 11:57 | ||
во-первых, непонятно, зачем здесь обе эти проверки. во-вторых, причина может быть в отсутствии переменной $HTTP_SESSION_VARS |
| Автор: Zzet 22.9.2009, 12:08 |
| сесии работают, что значит отсутствие переменной $HTTP_SESSION_VARS ? код ее не видит? или ее можно убрать и не проверять? Добавлено через 1 минуту и 3 секунды сесии работают, что значит отсутствие переменной $HTTP_SESSION_VARS ? код ее не видит? или ее можно убрать и не проверять? |
| Автор: Ипатьев 22.9.2009, 12:17 | ||
это значит отсутствие переменной $HTTP_SESSION_VARS вы, автор кода, задаете этот вопрос мне, постороннему человеку?
это вы писали? можете объяснить смысл этой конструкции? |
| Автор: Zzet 22.9.2009, 12:24 |
| я взял чужую обработку и вставил в свой код все работало без проблем до перехода на новый хостинг. |
| Автор: Simpliest 22.9.2009, 12:56 |
Если ты взял правильную строку (на которую ссылается ошибка), то у тебя в массиве $_REQUEST нет элемента с ключем it2. Это может быть в двух случаях -
|
| Автор: Ипатьев 22.9.2009, 13:43 |
| если это код из чужой разработки, то совсем неудивительно, что она не работает рекомендую http://captcha.ru |