Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > PHP: Общие вопросы > write failed: No space left on device


Автор: bars80080 21.9.2009, 16:53
вроде пишет ошибка пхп:

Цитата
[21-Sep-2009 11:26:38] PHP Warning:  Unknown: write failed: No space left on device (28) in Unknown on line 0
[21-Sep-2009 11:26:38] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0


выскочила сегодня такая ошибка на хосте. идентифицировал как: нехватка места для записи сессии. в итоге сессия не запускалась, но та часть сайта, что могла работать без сессии - отлично работала, включая БД.

в попытке быстро поправить, зашёл по фтп и снёс несколько залежалых дампов, мегабайт на 20 в сумме. немедленно запахал, сессии вновь заработали.
правда, спустя полчаса сайт отвалился целиком, пришлось в техподдержку звонить, они сообщили, что у них что-то зависло, и быстро восстановили (в течении минуты). вот этот последний пункт, наверное, не связан с предыдущим. отваливается у них чуть ли не каждый месяц.

сейчас наконец нарыл доступ к cPanel, смотрю, дисковое пространство заполнено всего на половину. ещё свободно 1,5ГБ

собсна, вопрос: что это было?
у них на жёстком физически закончилось место,
у меня висела какая-то не закрытая сессия и каким-то макаром не давала писать (это соображение высказал сисадмин, хз, как оно может быть)
или ещё что?

Автор: Simpliest 21.9.2009, 17:08
Скорее окончилось место.

Возможно каталог используемый для сессий(это кстати бывает каталог временных файлов) у них находится на отдельном томе и там кончилось место.

Добавлено @ 17:11
Цитата(bars80080 @  21.9.2009,  16:53 Найти цитируемый пост)
у меня висела какая-то не закрытая сессия и каким-то макаром не давала писать

Каким? Сессия может не давать писать только самой себе.

пальцем в небо - возможно проблема была с thread safety, но тогда это внутренняя ошибка php. Да и крайне маловероятно это.

Добавлено @ 17:13
Вот еще какой момент может быть. Слишком много файлов было в каталоге сессий. В результате чего новый файл не мог создаcться.

Добавлено @ 17:17
кстати, google говорит, что первая ошибка относится к MySQL.

Автор: MoLeX 22.9.2009, 05:55
Цитата(Simpliest @  21.9.2009,  17:08 Найти цитируемый пост)
Возможно каталог используемый для сессий(это кстати бывает каталог временных файлов) у них находится на отдельном томе и там кончилось место.

да, такая же фигня была недавно. и ошибки похожие. избавился от них только после очистки папки с сессиями

Автор: bars80080 22.9.2009, 10:29
Цитата(MoLeX @  22.9.2009,  05:55 Найти цитируемый пост)
избавился от них только после очистки папки с сессиями 

а где эта папка может быть на внешнем хосте?

в phpinfo() пишет 
session.save_path no value no value 
папочка tmp не содержит файлов с именами типа sess_0jvf2i25e35g89f9g6coc6es01

наверное, она вне моего доступа?

Автор: MoLeX 22.9.2009, 10:45
Цитата(bars80080 @  22.9.2009,  10:29 Найти цитируемый пост)
наверное, она вне моего доступа? 

 smile 

Автор: bars80080 22.9.2009, 12:02
придётся с техподдержкой бодаться

спасибо всем

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)