| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > PHP: Общие вопросы > Проблема с подключением к phpmyadmin |
| Автор: ruslandlion 26.9.2009, 13:25 |
| Уважаемые программисты, подскажите пожалуйста что мне делать? Дело в том что у меня стоит виртуальный сервер на моей машине Денвер 2, до этого момента он прекрасно работал, и вдруг перестаёт отвечать. Запускаю его (появляеться красное пёрышко в трее),открываю браузер Firefox. ввожу в адресную строку http://localhost/phpmyadmin , в ответ мне выдаётся ошибка "Firefox не может установить соединение с сервером localhost. Попытка соединения не удалась" Заранее спасибо. |
| Автор: ruslandlion 26.9.2009, 14:29 |
| Уважаемые программисты, подскажите пожалуйста что мне делать? Дело в том что у меня стоит виртуальный сервер на моей машине Денвер 2, до этого момента он прекрасно работал, и вдруг перестаёт отвечать. Запускаю его (появляеться красное пёрышко в трее),открываю браузер Firefox. ввожу в адресную строку http://localhost/phpmyadmin , в ответ мне выдаётся ошибка "Firefox не может установить соединение с сервером localhost. Попытка соединения не удалась". Заранее спасибо. |
| Автор: masp 26.9.2009, 14:59 |
| пропингуй localhost проверь работает ли апач |
| Автор: unicross 26.9.2009, 15:01 | ||
К phpmyadmin ваша проблема никакого отношения не имеет, так же как и к PHP... У вас не запускается Апач. Виной тому скорее всего установленные программы, которые занимают порт 80 или вы пытались редактировать конфигурационные файлы и допустили ошибку. Для проверки занятости порта в командной строке набираем команду:
В списке не должно быть строки с портом 80. Если есть, то Apache не сможет запуститься. Обычно этот порт занимают программы Skype и Web-сервер IIS. Если вы установили Skype: заходим в "Настройки -> Дополнительно -> Соединения" и снимаем флажок "Использовать порты 80 и 443 в качестве входящих альтернатив". P.S. Вы еще и несколько тем создали... |
| Автор: ruslandlion 26.9.2009, 15:09 | ||
Да пингует ответ поступает, апачи тоже работает вроде бы , пёрышко в трее есть. Уже 3 час мучаюсь с этой проблемой |
| Автор: Simpliest 26.9.2009, 15:25 |
Звездный совет Перышко до одного места. Зайди в сервисы и посмотри запущен ли аппач. Можешь еще чере TaskManager найти процесс httpd.exe если он есть - то копай дальше (например посмотри в конфигах на какой порт ты его повесил - 80й или другой). |
| Автор: ruslandlion 26.9.2009, 15:38 |
| К сожалению у меня это не сработало.Галочку снял в скайпе но безрезультатно. |
| Автор: ruslandlion 26.9.2009, 15:42 |
| 80 порт был занят программой Skype, я исправил эту ошибку, в сервисах апач запущен причём дважды? а он ### не работает |
| Автор: skyboy 26.9.2009, 15:44 | ||
|
| Автор: Simpliest 26.9.2009, 16:04 |
Да ну? Тогда убери скайп из автозапуска и перезагрузи машину. Должно заработать. Если не заработает - то надо читать ошибки. В MMC посмотреть events для приложения httpd.exe или Apache... Можно еще найти лог апача и посмотреть там (обычно это ...\...\Apache2\logs\error.log) |
| Автор: ruslandlion 26.9.2009, 16:32 | ||
Чувак, у меня и так скайп с автозапуска снят, но phpmyadmin не загружается, я на набрал команду в командной строке( сори за тофтологию) netstat -anb, по идее должно быть три процесса
а их там нету, что делать?Переустанавливать пробовал не получается. |
| Автор: Strilo4ka 26.9.2009, 23:15 |
| может еще что то 80 порт занимает!!!??????(или апач не перегрузил был когда снял отметку а skype). Может хтттп.конф изменял. И что то каряво записано с ошыбкой... Короче просто переустанови, тю проблема. |
| Автор: USD 21.11.2011, 19:43 |
| ....................... |
| Автор: $дмитрий 21.11.2011, 19:50 | ||
Жми кнопку "Пуск" в поле "Найти программы и файлы" впиши "cmd" появится окошко, далее пиши "ping localhost" и нажимай enter |
| Автор: USD 21.11.2011, 20:01 |
| ............................. |
| Автор: $дмитрий 21.11.2011, 20:08 | ||
А виндой тоже пару дней пользуешься? Кнопка "Start", она же локализованная "Пуск" находится в левом-нижнем углу, такаешь в нее, потом в поле которые чуть выше вводишь cmd и т.д. |
| Автор: USD 21.11.2011, 20:18 |
| ........................ |
| Автор: $дмитрий 21.11.2011, 20:29 |
| Апач в процессах висит? |
| Автор: USD 21.11.2011, 20:36 |
| .......................... |
| Автор: $дмитрий 22.11.2011, 09:21 | ||||
|
| Автор: USD 22.11.2011, 09:23 |
| ......................... |
| Автор: USD 22.11.2011, 09:39 |
| ................... |
| Автор: MoLeX 22.11.2011, 09:49 | ||
сказки говорите. скриншот вас с потрохами сдает. и мой вам совет - учите основы основ работ с ПК. Если вы самого простого незнаете, то зачем вам программировать? |
| Автор: USD 22.11.2011, 09:54 |
| .......................... |
| Автор: bobik02 22.11.2011, 14:31 |
| facepalm.jpg |
| Автор: ksnk 22.11.2011, 15:04 |
| Нужно ткнуть кнопкой мыши в это самое "перышко" в трее. Если оно тут-же пропало, то ткнуть в следующее Если и второе пропало - запустить Денвер и постараться успеть ткнуть в перышко до того как Денвер схлопнется. Там будет окно с сообщением о старте апача. Как правило, при нормальном старте сообщение состоит из одной строки. Если сообщение заканчивается чем-то вроде "ждем еще 9-8-7... секунд и закрываемся", произошла ошибка. Сообщения об ошибках также сваливаются в лог-файл, который стандартно находится по адресу c:\WebServers\usr\local\apache\logs\error.log последние сообщения, с близкой к реальности датой и будут последними сообщениями о проблемах при старте. |