Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > PHP: Общие вопросы > Не работает PhpMyAdmin


Автор: usa1450 7.1.2015, 17:55
Не работает PhpMyAdmin

Захожу на http://localhost/phpmyadmin/ выдает ошибку:

Код

Fatal error: Call to undefined function mb_detect_encoding() in
F:\apache\htdocs\www\phpmyadmin\libraries\php-gettext\gettext.inc on line 177
В папке f:\apache\htdocs\www\phpmyadmin\ лежит PhPMyAdmin



Как исправить ошибку?

user posted image
user posted image
user posted image
user posted image

Автор: gami 7.1.2015, 22:01
1. В файле php.ini убрать ; и указать полный путь extension_dir к каталогу ext
2. Там же убрать ; перед командой extension = mb_string
3. Проверить конфигурацию функцией phpinfo() в тестовом php файле
4. Прочитать вывод сообщений в logs/error.log
5. После всех манипуляций необходимо перегрузить сервер Apache

Этот ответ добавлен с нового Винграда - http://ru.vingrad.com/Ne-rabotayet-PhpMyAdmin-id54ad493fae2015835d8b4567#findElement_E7045_54ad8276ae201530158b46c8_0

Автор: usa1450 8.1.2015, 14:21
Вроде как прописал, убрал ";" и перезагрузил апач, но ошибка все равно выбивает 
Код


Fatal error: Call to undefined function mb_detect_encoding() in F:\apache\htdocs\www\phpmyadmin\libraries\php-gettext\gettext.inc on line 177


user posted image

Автор: Starikan 8.1.2015, 19:56
убери эту функцию, че ты к ней привязался

Автор: usa1450 9.1.2015, 19:10
Перезалил, скачал новую версию phpMyAdmin-4.3.6-all-languages.zip и разархивировал в папку phpmyadmin F:\apache\htdocs\phpmyadmin.
Настроек в phpmyadmin не менял, запускаю http://localhost/phpmyadmin/
Ошибка:

Код

Fatal error: Call to undefined function mb_detect_encoding() in 
F:\apache\htdocs\phpmyadmin\libraries\php-gettext\gettext.inc on line 177

Автор: Sanchezzz 10.1.2015, 01:54
Убедитесь что модуль php_mbstring установлен в 

это файл ...php55/ext/php_mbstring.dll  если у вас его нет скачайте под конкретно вашу версию.
Дальше файл нужно положить в папку ext
В файле php.ini  
добавить в секцию конфига [PHP] строчку 
Код

extension=php_mbstring.dll

ps. динамичное подключение библиотек не использу, только конфиг только хардкор.

Автору посоветую скачать нормальный локальный сервер.
 xampp или winginx где все настроено и большинство модулей есть.

Автор: usa1450 10.1.2015, 02:43
Файл php_mbstring.dll у меня есть и лежит по адресу F:\apache\php\ext
user posted image

Прописал PHPIniDir "F:/apache/php" в httpd.conf

Вот содержимое PATH в переменных среды:
Цитата
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;
%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;f:\apache\php;f:\apache\php;
f:\apache\bin;c:\Program Files\MySQL\MySQL Server 5.5\bin\


Кинул файл php.ini в каталог C:\Windows  и в C:\Windows\system32 и все равно ошибка 

Цитата

Fatal error: Call to undefined function mb_detect_encoding()
 in F:\apache\htdocs\phpmyadmin\libraries\php-gettext\gettext.inc on line 177


user posted image
user posted image
user posted image

Автор: whatisnot 10.1.2015, 11:44
При "всем на месте", необходимо чтобы это "все" было и версии одной. Забудьте пока о РМА, в сриптах эта библиотека работает, проблем нет?

А вообще, что вам надо - крутой сервер и иметь к несу доступ извне, или же удобный и хороший локальный сервер для отладки скриптов? Если последнее, то скачивайте http://open-server.ru/, это действительно хороший сервер для таких целей. Установки как таковой не требуется. И если в системе не один физический диск, то не распаковывайте его на системный.

Кстати о РМА, вроде бы чем дальше, тем хуже, в последних версих появилсиь такие моменты, которое не радуют. Кроме РМА есть и другие инструменты. 

Автор: usa1450 10.1.2015, 12:05
Ребята, кто-то может подсказать что нужно подправить в каком файле чтобы запустился PhPMyAdmin чтобы заработало?
Скачать готовую сборку я могу в любой момент и здесь не спрашивая, у меня все готово, только не запускается PhPMyAdmin,  выдает ошибку:

Код

Fatal error: Call to undefined function mb_detect_encoding() in F:\apache\htdocs\phpmyadmin\libraries\php-gettext\gettext.inc on line 177


Как исправить?

Автор: usa1450 10.1.2015, 14:10
Перезагрузил компьютер, удалил с диска C\Windows\php.ini и с C:\Windows\system32\php.ini  И в pathу убрал лишнее прописал:

Код
C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32
\WindowsPowerShell\v1.0;f:\apache\php;c:\Program Files\MySQL\MySQL Server 5.5\bin\


Оказывается почему-то фал в Notepad++ после нажатии на иконку "сохранить",не сохранил файл php.ini. Зашел через пункт "Файл"->"Сохранить как" и исправил.
user posted image

Автор: Starikan 11.1.2015, 19:46
ну вот опять ты начинаешь.. нормально же всё объяснил.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)