Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > PHP: Общие вопросы > php expert editor!


Автор: Ivushka 17.11.2005, 11:35
Помогите!!!!
Почитала тему про лучшие проги для работы с php.
решила установить php expert editor.
Скачала, установила, поставила php....
а он не работает!!!
мои странички на сервере, подключение настроила, открыла страницу, исправить можно но про открытии страницы в php expert editor пишет ошибки!!!!
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2) Character set '#17' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file Could not connect : Access denied for user: ******** (Using password: NO)
не могу понять про что он....... smile

Подскажите что делать или где искать описание!!!! smile


Он что работает только с сервака?????

Автор: Bangladesh 17.11.2005, 22:18
если качала с неоффициального сайта, то может быть все... собственно, качай с сайта Ankord -http://www.ankord.com/. регистрируйся там же. для жителей СНГ регистрация бесплатно... (freeware)

Автор: -=Ustas=- 17.11.2005, 23:06
Цитата(Ivushka @ 17.11.2005, 11:35)
Could not connect : Access denied for user: ******** (Using password: NO)

Тут же русским языком написано, нет доступа. Проверь реквизиты доступа к БД.
Цитата(Ivushka @ 17.11.2005, 11:35)
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2) Character set '#17' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file

Наверное денвера юзаешь?!

Автор: R.M. 18.11.2005, 01:18
-=Ustas=-
Цитата
Цитата (Ivushka @ 17.11.2005, 11:35)
Could not connect : Access denied for user: ******** (Using password: NO)

Тут же русским языком написано, нет доступа. Проверь реквизиты доступа к БД.

Русским? smile

Походу дело в том что прога не зарегана, а вообще зачем эти проги нужны? в них ничего полезного нету, если не щитать номера строк (ИМХО) smile

Автор: -=Ustas=- 18.11.2005, 01:51
Цитата
Походу дело в том что прога не зарегана

Регистрация тут не при чем.

Цитата
а вообще зачем эти проги нужны? в них ничего полезного нету, если не щитать номера строк (ИМХО)

Удобство написания программ, в отличие от их написания в обычном блокноте + удобная и быстрая отладка программ.

Автор: Ivushka 18.11.2005, 13:14
Качала с официального сайта.
Регистрация есть.
траблы с rood directory
объясните если я подключаюсь к серверу не в корень /var/www/html/Intranet/ может быть путь???
он не видит файла в rood directory хотя открываю я с ftp smile
Добавлено @ 13:20
Вроде подключение наладила только теперь опять вернулась к ошибкам(((
если отлаживать на локальном компе то страницы работают а с сервера ошибки выдает(((((((((((((((
smile

Автор: R.M. 19.11.2005, 01:17
Ivushka

Какие именно ошибки выдаёт?

Автор: -=Ustas=- 19.11.2005, 08:33
Мне что-то не понятно, что ты пытаешься сделать - настроить отладчик, или же у тебя ошибки в скриптах?!

Автор: Ivushka 22.11.2005, 13:21
вот такие ошибки
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2) Character set '#17' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file Could not connect : Access denied for user: 'site@***.***.***.***' (Using password: NO)
это на сайте видно вместо отображения таблицы по запросу
он не может подключиться к mysql!!!

Автор: -=Ustas=- 22.11.2005, 16:22
Цитата(Ivushka @ 22.11.2005, 13:21)
он не может подключиться к mysql!!!

Правильно, не может. Есть две причины, по которым он не может подключиться к мускулу, либо неправильное имя/пароль, либо сервак в дауне...Проверяй правильность.

Автор: Ivushka 22.11.2005, 17:03
Пароль и логин в норме только я задаю их через mysql_connent а он пишет "логин"@IP и читает это целиком!!!

Добавлено @ 17:04
а сервак нормальный с Dreamweaver все работает

Автор: R.M. 23.11.2005, 01:20
Ivushka

Пиши отдельно и лучше через переменные.

Цитата(Ivushka @ 22.11.2005, 18:03)
а сервак нормальный с Dreamweaver все работает

А при чём тут дримвивер? smile

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)