Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Perl: Системное программирование > Установка 4site


Автор: mok 20.5.2008, 14:55
Помогите с установкой системы на денвер.

Подробно на чем я споткнулся

http://vash-ru.net/help4silte/help.htm

Автор: shamber 20.5.2008, 16:13
mok, обратитесь на сайт Денвера.
Там вам помогут

Автор: mok 20.5.2008, 17:11
Цитата(shamber @ 20.5.2008,  16:13)
mok, обратитесь на сайт Денвера.
Там вам помогут

Для начала я естественно перелопатил поиск. Были уже обращения подобного рода на форуме денвера, они отсылали к разработчикам. И были правы, Дело не в установке доп. модулей, а в запутанной документации по установке. 

 Software error:
Can’t call method “do” on an undefined value at modules/NoSOAP.pm line 39.

sub connectDB {
    my $self = shift;
    my ($db,$host,$user,$pass) = @_;
    my $dbi = "dbi:mysql:$db:$host";
    $self->{dbh} = DBI->connect($dbi,$user,$pass);
line 39    $self->{dbh}->do("SET NAMES cp1251");
}

Открыл код демо сайта, там вообще не определена кодировка , отсутствует
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251" />

Может из-за этого?

Автор: mok 20.5.2008, 17:45
Ксок файла настроек демо сайта

Код
Содержит хэш настроек MySQL.

=over 4

=item C<user>

=item C<pass>

=item C<database>

=item C<host>

Понятно, что здесь... :)

=back

=head3 C<secur>



Подскажите, что для вас понятно

Автор: nirburg 20.5.2008, 18:27
mok, эта ошибка не относится к кодировке страницы.

Код

$self->{dbh} = DBI->connect($dbi,$user,$pass);
$self->{dbh}->do("SET NAMES cp1251");


причиной "Can’t call method “do” on an undefined value", очевидно, является undef, возвращаемый DBI->connect. вероятно, $dbi, $user или $pass установлены некорректно, попробуйте проверить их значения.

Автор: mok 20.5.2008, 20:04
Поменял базу (было root c пустым паролем)

Прописал в обоих Settings.pm (multisite & demo), без изменений.

Так что это в 13 строке (Понятно, что здесь... smile) с улыбочкой

И еще в Settings.pm 

Код
=head1 BUGS

No known ones yet. ;))



Я может и воспользовался помощью разработчиков в установке за 300 баксов (очень дорого), но должен же определиться с системой, а на ихней демке тоже какие то глюки.

Система заманчивая
1)  система управления отдельная, с возможностью установки на локале. 
 
2) страницы сохраняются в статичных файлах с поддержкой ssi

Автор: nitr 21.5.2008, 00:54
mok, почитайте там, где описано про конфигурацию системы. Как вам уже подсказали - обращайтесь на портал Денвера.
Ваши "глюки"/проблемы к Perl практически не относятся. Как понимаю ошибка в неком модуле "системы", у которой даже нет самой обычной проверки на ошибки, или хотя бы вывода ошибки!

nirburg, вам ответил что это за ошибка. Прочтите документацию по конфигурации/настройке системы.
Ещё совет: посмотрите логи ваше веб-сервера, там обычно бывают "подсказки".
А разбирать баги или недоработки "системы" - это другая история, для этого есть у "системы" разработчики...

P.S.:
300$ - это они классно придумали находить л***в. Хотя не видел я их системы smile и не буду смотреть, уже кое-что ужасает...


Автор: Nab 27.6.2008, 00:19
Система неплохая, не надо их ругать smile Хотя мне некоторая негибкость не понравилась, слишком там жесткие требования ко многим параметрам софта и хостинга.

Автор: gcc 27.6.2008, 10:25
do поменять на prepare  smile 

ЗЫ: это при установке? это просто БД ставиться в кодировку соответсвующую наверное, можно это удалить... и поставить руками cp1251, если я правильно понял

Автор: KSURi 27.6.2008, 11:51
gcc, а это еще зачем? do, согласно документации, обычно используется при "non-SELECT  statements".

Автор: gcc 28.6.2008, 09:03
может попробовать изменить то, что не работает...

Автор: Vadfloyd 4.7.2008, 23:15
Всем спасибо, вопросов больше нет. Поставил другую смс.

Удачи!

Автор: gcc 5.7.2008, 01:05
1) права доступа поставить соответствующие chmod 750
2) почитать документацию к установке

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)