| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Разработка под ASP.NET > Как запустить службу win srevices из Asp.net |
| Автор: draiv 23.6.2008, 18:21 |
| Подскажите, что нужно сделать чтобы запустить службу из Asp.Net Использую ServiceController. В виндовс приложении служба запускается/останавливается нормально. А в Asp.Net при запуске выдает 'access is denied'. Пробовал выставлять для службы Asp.net-овский аккаунт - тогда и руками служба не запускается, говорит "The service did not start due to a logon failure". Что де надо сделать, чтоб запускать службу из под Asp.Net? |
| Автор: Idsa 23.6.2008, 19:15 |
По-моему так эта проблема и лечится. Только нужно поставить аккаунт Local System. |
| Автор: draiv 24.6.2008, 10:49 |
| У меня в списке не видно акаунта Local System - есть LocalService, но когда выставляю его то при запуске службы выдается мессага --------------------------- Services --------------------------- The MyService service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service. --------------------------- OK --------------------------- |
| Автор: Idsa 24.6.2008, 14:40 |
| draiv, может, http://uekb.shavlik.com/UpdateEXPERT/TroubleShooting/Messages/UE0418.htm поможет. |
| Автор: PashaPash 24.6.2008, 15:53 |
| draiv, access is denied при попытке запуска означает что у того аккаунта, под которым работает приложение ASP.NET, нет прав на запуск службы. И нужно менять аккаунт, под которым работает приложение ASP.NET, а не аккаунт службы. Дальше все зависит от версии IIS/ASP.NET. Под вистой или 2003-й можно сменить пользователя для пула приложений asp.net. Под любой версией можно сменить пользователя для asp.net вообще (http://support.microsoft.com/kb/317012) или имперсонировать его на время одного запроса (http://support.microsoft.com/kb/306158). |
| Автор: draiv 24.6.2008, 17:58 |
| спасибо |