Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > PHP: Extensions > PDO OCI. Не запускается apache


Автор: m_maxser 25.7.2012, 08:25
Здравствуйте

Пытался настроить локальный сервер. Для работы с БД (Oracle) в нескольких проектах используется PDO. Все это настроено на нескольких ПК. Ставлю апач - все нормально. Ставлю php - Апач не запускается. 

Гуглил, советуют комментировать в php.ini несколько библиотек, в том числе php_pdo_oci.dll и php_pdo_oci8.dll. Комментировал - помогает smile. Проблема в том, что они мне как раз нужны. Пробовал полностью переносить сервер с компьютера на котором  все это работает, тот же результат. 

Сравниваю, не вижу разницы, но на моем ПК не работает. В лог ничего не пишет, просто сообщение "The requested operation has failed!".

Ничего не понимаю, настраивал все это на другом компе, тоже не с первого раза, но проще было. А тут с пятницы вожусь.

Apache 2.2 ставил инсталером (msi)
php 5.2.12 ставил инсталером (msi)
Windows 7 новая, только-что поставил

Автор: m_maxser 4.3.2013, 08:44
много времени прошло, но проблема актуальна

Автор: m_maxser 4.3.2013, 09:16
возможно проблема в пхп, т.к. при запуске из командной строки просто вылетает без предъявления ошибки. Если закоментировать в ini-файле php_pdo_oci8.dll, то запускается.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)