Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > PHP: Сеть > Настройка PHP для работы с удаленными файлами


Автор: -=Ustas=- 17.11.2005, 11:06
Мое почтение!
Скажите, в чем может быть проблема. Вот код, который юзаю:
Код

$out = implode(' ', file('http://www.host.ru/output_file.php'));

На серваке у хостера работает нормально, у меня на локалке не хочет, кричит типа: file(http://www.host.ru/output_file.php): failed to open stream: Bad file descriptor in... , implode(): Bad arguments...
Хотя в php.ini - allow_url_fopen = On. Что это за трабла?

Автор: Bikutoru 17.11.2005, 11:14
Нужен allow_url_fopen = on
Цитата

If PHP has decided that filename specifies a registered protocol, and that protocol is registered as a network URL, PHP will check to make sure that allow_url_fopen is enabled. If it is switched off, PHP will emit a warning and the fopen call will fail.

Автор: -=Ustas=- 17.11.2005, 13:51
Bikutoru, я же написал:

Цитата
Хотя в php.ini - allow_url_fopen = On. Что это за трабла?


Автор: MuToGeN 17.11.2005, 14:46
какой версии PHP?

Автор: -=Ustas=- 17.11.2005, 14:59
4.3.11
В phpinfo показывает allow_url_fopen Local:On Master:On
У меня просто соединение прокси (ISA Server), с ним там еще firewall майкрософтовский стоит. Мож он не поускает? Если да, то как это обойти? Или это в самих настройках прокси ковыряться надо?

Автор: MuToGeN 17.11.2005, 20:34
...ну тогда все ясно, причина в проксе.
Как приучить PHP к работе с прокси - понятия не имею. AFAIK, вообще невозможно без использования сокетов.

Автор: Bikutoru 18.11.2005, 09:35
Цитата
Bikutoru, я же написал:

Цитата
Хотя в php.ini - allow_url_fopen = On. Что это за трабла?

Извини, не внимательно прочитал smile

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)