Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > MS Windows > Ошибка DNS


Автор: Akella 19.8.2006, 11:36
Пару недель назад в "событиях" DNS-сервера ОС - Win2003 Server, стала появлятья такая ошибка
На сайте MS нет нормального описания этой проблемы, мож кто сталкивался?
Поднят AD на этом компе.
Ошибка проявляется три раза в сутки.
Сервер установлен пол-года назад, примерно. До этого не проявлялась эта ошибка.
Цитата
Тип события:    Ошибка
Источник события:    DNS
Категория события:    Отсутствует
Код события:    6702
Дата:  19.08.2006
Время:  8:00:56
Пользователь:  Н/Д
Компьютер:    SERVER
Описание:
DNS-сервер обновил свои записи узла (A). Чтобы убедиться, что с этими интегрированными в DS равноправными DNS-серверами можно провести репликацию с данным сервером, была произведена попытка их динамического обновления с новыми записями. При этом обновлении произошла ошибка. Данные записи содержат код ошибки. 
 
Если этот DNS-сервер не имеет интегрированных в DS партнеров по репликации, 
то это сообщение об ошибке можно пропустить. 
 
Если партнеры репликации Active Directory этого DNS-cервера имеют неправильные IP-адреса этого сервера, то они не смогут проводить репликацию с ним. 
 
Чтобы убедиться в правильном проведении репликации: 
1) Найдите партнеров репликации Active Directory данного сервера, на которых запущен DNS-сервер . 
2) Откройте "Диспетчер DNS" и подключитесь по очереди к каждому из партнеров по репликации. 
3) На каждом сервере, проверьте регистрацию узла (запись типа A) для ЭТОГО сервера. 
4) Удалите любые записи (A), которые НЕ связанны с IP-адресами этого сервера. 
5) Если для этого сервера отсутствуют записи типа (A), добавьте как  минимум одну запись (A), связанную с адресом этого сервера, с которой  партнер по репликации может контактировать. (Другими словами, если для данного  DNS-сервера существует несколько IP-адресов, добавьте по крайней мере один, который находится в той же сети, что и обновляемый Active Directory DNS-сервер.) 
6) Отметьте, что не обязательно обновлять сведения КАЖДОГО партнера по репликации. Это необходимо только для тех, чьи записи исправляются, чтобы  каждый сервер, реплицирующий данные этого сервера, получал после репликации новые данные.

Дополнительные сведения можно найти в центре справки и поддержки, в "http://go.microsoft.com/fwlink/events.asp".
Данные:
0000: 7c 26 00 00               |&..    

Автор: Конструктор 19.8.2006, 21:50
Посмотри здесь, мабуть поможет
http://eventid.net/display.asp?eventid=6702&eventno=294&source=DNS&phase=1

Добавлено @ 21:52 
Кстати как называется домен? Если он назван одним словом, например "mydomain" то тогда будет немало всяких ошибок

Автор: Akella 23.8.2006, 10:57
а как жешь его назвать?

Добавлено @ 11:01 
это и на русском написано на сайте MS
Цитата
DNS Server has updated its own host (A) records. In order to insure that its DS-integrated peer DNS servers are able to replicate with this server, an attempt was made to update them with the new records through dynamic update. An error was encountered during this update, the record data is the error code. 

If this DNS server does not have any DS-integrated peers, then this error should be ignored. 
If this DNS server's ActiveDirectory replication partners do not have the correct IP address(es) for this server, they will be unable to replicate with it.

To insure proper replication: 
1) Find this server's ActiveDirectory replication partners that run the DNS server. 
2) Open DnsManager and connect in turn to each of the replication partners. 
3) On each server, check the host (A record) registration for THIS server. 
4) Delete any A records that do NOT correspond to IP addresses of this server. 
5) If there are no A records for this server, add at least one A record corresponding to an address on this server, that the replication partner can contact. (In other words, if there multiple IP addresses for this DNS server, add at least one that is on the same network as the ActiveDirectory DNS server you are updating.) 
6) Note, that is not necessary to update EVERY replication partner. It is only necessary that the records are fixed up on enough replication partners so that every server that replicates with this server will receive (through replication) the new data. 

Автор: Akella 23.8.2006, 13:02
Цитата
This Error occurs, when on a Server, that is providing the DNS-Service; the Server tries to register his own addresses in the DNS-Server. In the TCP/IP-Settings of each Network adapter and all RAS-Connections uncheck under DNS "register the addresses of this connection". This should help you get rid of this problem.

Попробовал это, посмотри, что будет

Автор: Akella 23.8.2006, 16:09
не помогает

Автор: Конструктор 26.8.2006, 20:43
Цитата(Akella @  23.8.2006,  11:57 Найти цитируемый пост)
а как жешь его назвать?


Это я к тому что например стоило назвать my.domain.com

Автор: Akella 28.8.2006, 08:37
Цитата(Конструктор @  26.8.2006,  20:43 Найти цитируемый пост)
Это я к тому что например стоило назвать my.domain.com

зачем? смысл....

Автор: Akella 31.8.2006, 13:01
тема ещё актуальна

Автор: Конструктор 7.9.2006, 21:43
Цитата(Akella @  28.8.2006,  09:37 Найти цитируемый пост)
зачем? смысл....


Смысл в том что судя по откликам на том сайте где я кидал линк винду немножко плющит с такими односложными доменами.

Автор: Akella 12.9.2006, 10:17
тема всё ещё актуальна

Автор: Akella 26.9.2006, 17:23
а тема всё ещё актуальна

Автор: Akella 1.11.2006, 16:15
сегодня утром чего-то здесь (см. рис.) поменял, чего не помню. smile

Добавлено @ 16:17 
dsdiag  - всё "passed"

Добавлено @ 16:18 
кроме
Цитата

      Starting test: systemlog
         An Error Event occured.  EventID: 0x80001774
            Time Generated: 11/01/2006   15:13:10
            (Event String could not be retrieved)
         ......................... SERVER failed test systemlog
      Starting test: VerifyReferences
         ......................... SERVER passed test VerifyReferences


Добавлено @ 16:28 
с dnslint не допру чё делать

Автор: Akella 3.11.2006, 17:35
Великое спасибо to LocalHost. С  бубном и шаманскими плясками  smile  он победил ентот DNS. Ставлю сразу +++.

Автор: localhost 3.11.2006, 17:43
Akella, эээ спасибо, конечно smile если бы это было в начале рабочего дня, то справились бы быстрее smile

Автор: Akella 3.11.2006, 17:47
да, башкА кипела и RAdmin`у (программе) respect.
При первом удобном случае буду у начальства просить деньги на покупку ентой замечательной проги

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)