Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > MS Windows > Appcrash при установке в Windows Server 2008


Автор: Натка 5.7.2013, 12:31
Проблема заключается в следующем: при установке некой программы в Windows Server 2008 R2 Enterprise (SP1) вылетает ошибка о прекращении работы программы с именем события проблемы appcrash (имя модуля с ошибкой - StackHash_2264), и установка завершается. 

Проэксперементировано, что тоже самое наблюдается на Windows 7, но XP таких проблем не вызывает. И все бы ничего, можно было бы говорить о несовместимости данной программы с новым поколением систем, но более года назад я ставила эту же программу на сервер Windows Server 2008 Standard Service Pack 2, и где-то в это же время - на семерку, но, хоть убейте, в упор не помню, чтобы эта проблема возникала!!

Пыталась и путь установки с именем файла делать без пробелов, на латинице, добавляла в исключения DEP программу установки, потом вовсе отключила DEP, но, увы, ничто не помогает(((

Кто сталкивался с подобным?? Помогите!!

Автор: dstorm81 12.7.2013, 11:49
Цитата(Натка @  5.7.2013,  12:31 Найти цитируемый пост)
при установке некой программы

как бы лицезреть эту некую программу

Автор: Натка 12.7.2013, 12:01
Не, не лицезрите) это китайская скада-система)

Вопрос к аудитории: здесь всегда такой мертвый форум?? В первый раз написала, и такая тишина в ответ) который день наслаждаюсь)

Автор: dstorm81 12.7.2013, 12:08
Цитата(Натка @  12.7.2013,  12:01 Найти цитируемый пост)
Не, не лицезрите) это китайская скада-система)

тогда на форум китайских товарищей за помощью...
Цитата(Натка @  12.7.2013,  12:01 Найти цитируемый пост)
здесь всегда такой мертвый форум?? В первый раз написала, и такая тишина в ответ) который день наслаждаюсь) 

оффтоп:
раньше, когда все были молодыми, могли забросать всякими попробуй так.. или попробуй эдак, сейчас же, все повзрослели и игнорируют вопросы о сферических программах на сферических компах сферических юзеров..

Добавлено через 6 минут и 13 секунд
и еще..раз уж добрый такой сегодня
 xp 32 битная скорее всего была... 7 ки бываю и 32 и 64 битнаые...
 Windows Server 2008 R2 Enterprise (SP1)- ТОЛЬКО 64 битная
Windows Server 2008 Standard Service Pack 2 может быть и 32 и 64 разрядной

так что разберись с битностью

Автор: Натка 12.7.2013, 12:28
Во-первых, не в битности дело, та, на которой ставилось успешно - 64-разрядная, на которую ставлю сейчас - тоже. В интернете, насколько я искала, нигде не связывают ошибку appcrash с битностью.

Во-вторых, про специфику программы - не суть важен вопрос, тут уже дело в некой совместимости с новыми системами речь идет (ну очень похоже на то). 

В-третьих, китайцы любезно сообщили, что ошибки, в принципе, должны быть, потому что данная программа и должна работать с WinServer2003 и нечто подобным, но никак не с новыми системами. НО! Я же писала, что более года назад ставила на 2008 - и такой ошибки не было. Либо какие-то обновления накатились... 

За ответ спасибо, посылать больше меня к китайцам не надо) Может, кто-то сталкивался с такой ошибкой в принципе (с любой другой программой)?? И как ее решали?? Просто интересно, с чем еще это может быть связано

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)