Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Perl: Общие вопросы > Apache2 + fastCGI


Автор: frenkys 18.3.2006, 17:04


Код

[Sat Mar 18 15:59:11 2006] [crit] (OS 3)Системе не удается найти указанный путь.  : FastCGI: can't start (dynamic) server "C:/inet/localhost/cgi/11.fpl": spawn_fs_process() failed
[Sat Mar 18 15:59:16 2006] [alert] [client 127.0.0.1] FastCGI: failed to connect to (dynamic) server "C:/inet/localhost/cgi/11.fpl": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive
[Sat Mar 18 15:59:16 2006] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "C:/inet/localhost/cgi/11.fpl"




Люди у кого на локалке получилось настроить в апач2 FCGI ?

что в конфиге писали?

Автор: tishaishii 18.3.2006, 18:31
Нафига? Пользуй mod_perl.
В конфиге писал:
Код
LoadFile "E:/home/etc/mod_perl2/Perl/bin/perl58.dll"
LoadModule perl_module modules/mod_perl.so

...........................


<FilesMatch ^[\w\-]+$>
    Sethandler perl-script
    PerlResponseHandler ModPerl::RegistryBB
    Options +ExecCGI
</FilesMatch>

Автор: frenkys 18.3.2006, 23:19
этоконечно хорошо но все же как ля фаст сделать?

Автор: nitr 19.3.2006, 00:57
Читай http://search.cpan.org/~lds/CGI.pm-3.17/CGI/Fast.pm
и конечно http://www.fastcgi.com/mod_fastcgi/docs/mod_fastcgi.html и http://www.fastcgi.com/mod_fastcgi/INSTALL

Автор: frenkys 19.3.2006, 01:11
Вот что имеем:

Apache 2.0.55
Win XP sp2
mod_fastcgi-SNAP-0404142202-AP2.dll



________________________________________

LoadModule fastcgi_module modules/mod_fastcgi.dll


AddType application/x-httpd-fcgi .fcgi .fpl
FastCgiServer C:/inet/localhost/cgi/11.fpl -processes 2

_________________________________________
в логи пишет:


[Sat Mar 18 23:55:28 2006] [crit] (OS 3)Системе не удается найти указанный путь. : FastCGI: can't start server "C:/inet/localhost/cgi/11.fpl": spawn_fs_process() failed
[Sat Mar 18 23:55:38 2006] [error] [client 127.0.0.1] (OS 109)Канал был закрыт. : FastCGI: comm with server "C:/inet/localhost/cgi/11.fpl" aborted: GetOverlappedResult() failed
[Sat Mar 18 23:55:38 2006] [crit] (OS 3)Системе не удается найти указанный путь. : FastCGI: can't start server "C:/inet/localhost/cgi/11.fpl": spawn_fs_process() failed
[Sat Mar 18 23:55:38 2006] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "C:/inet/localhost/cgi/11.fpl"
[Sat Mar 18 23:55:48 2006] [crit] (OS 3)Системе не удается найти указанный путь. : FastCGI: can't start server "C:/inet/localhost/cgi/11.fpl": spawn_fs_process() failed

Автор: nitr 19.3.2006, 01:59
А это не помогало?

FastCgiServer "C:/inet/localhost/cgi/11.fpl" -processes 2

Автор: frenkys 19.3.2006, 02:11
Цитата(nitr @ 19.3.2006, 01:59)
А это не помогало?

FastCgiServer "C:/inet/localhost/cgi/11.fpl" -processes 2

[Sun Mar 19 01:10:53 2006] [crit] (OS 3)Системе не удается найти указанный путь. : FastCGI: can't start server "C:/inet/localhost/cgi/11.fpl": spawn_fs_process() failed
[Sun Mar 19 01:10:53 2006] [notice] Child 9796: Starting 250 worker threads.
[Sun Mar 19 01:11:03 2006] [error] [client 127.0.0.1] (OS 109)Канал был закрыт. : FastCGI: comm with server "C:/inet/localhost/cgi/11.fpl" aborted: GetOverlappedResult() failed
[Sun Mar 19 01:11:03 2006] [crit] (OS 3)Системе не удается найти указанный путь. : FastCGI: can't start server "C:/inet/localhost/cgi/11.fpl": spawn_fs_process() failed
[Sun Mar 19 01:11:03 2006] [error] [client 127.0.0.1] FastCGI: incomplete headers (0 bytes) received from server "C:/inet/localhost/cgi/11.fpl"

Автор: sharq 20.3.2006, 17:00
frenkys, вот что у меня в конфе:
Код

LoadModule fastcgi_module modules/mod_fastcgi.dll

AddType application/x-httpd-fcgi .fcgi .fpl .fcg


Смотри мою dll. (надеюсь ты dll туда положил и остановил и заново запустил вирт. сервер)
Только переименуй в mod_fastcgi.dll.

smile
Добавлено @ 17:01
Пример, стандартный из документации:

Код

#!/usr/bin/perl
use FCGI;
use CGI::Carp qw(fatalsToBrowser);

# Initialization code
$cnt = 0;

# Response loop
while (FCGI::accept >= 0) {
  print "Content-type: text/html\r\n\r\n";
  print "<head>\n<title>FastCGI Demo Page (perl)</title>\n</head>\n";
  print  "<h1>FastCGI Demo Page (perl)</h1>\n";
  print "This is coming from a FastCGI server.\n<BR>\n";
  print "Running on <EM>$ENV{SERVER_NAME}</EM> to <EM>$ENV{REMOTE_HOST}</EM>\n<BR>\n";
   $cnt++;
  print "This is connection number $cnt\n";
}



Автор: frenkys 20.3.2006, 17:58
Тажа фигня

[Mon Mar 20 16:57:58 2006] [notice] Apache/2.0.55 (Win32) mod_fastcgi/2.4.2 configured -- resuming normal operations
[Mon Mar 20 16:57:58 2006] [notice] Server built: Oct 9 2005 19:16:56
[Mon Mar 20 16:57:58 2006] [notice] Parent: Created child process 4372
[Mon Mar 20 16:57:59 2006] [notice] Child 4372: Child process is running
[Mon Mar 20 16:57:59 2006] [notice] Child 4372: Acquired the start mutex.
[Mon Mar 20 16:57:59 2006] [notice] FastCGI: process manager initialized
[Mon Mar 20 16:57:59 2006] [notice] Child 4372: Starting 250 worker threads.
[Mon Mar 20 16:58:01 2006] [error] [client 127.0.0.1] (OS 3)Системе не удается найти указанный путь. : couldn't create child process: 720003: 11.fpl
[Mon Mar 20 16:58:01 2006] [error] [client 127.0.0.1] (OS 3)Системе не удается найти указанный путь. : couldn't spawn child process: C:/inet/localhost/cgi/11.fpl
[Mon Mar 20 16:58:02 2006] [error] [client 127.0.0.1] (OS 3)Системе не удается найти указанный путь. : couldn't create child process: 720003: 11.fpl
[Mon Mar 20 16:58:02 2006] [error] [client 127.0.0.1] (OS 3)Системе не удается найти указанный путь. : couldn't spawn child process: C:/inet/localhost/cgi/11.fpl

Автор: skalex 20.3.2006, 18:11
Я прикручивал FastCGI к Apache, но только не для Perl, а для Ruby. Работает ...

Что могу сказать? Надо еще в windows\system32 положить кое что ...
Прикрепляю необходимую dll.

Автор: frenkys 20.3.2006, 18:43
неа, нехочет все равно работать

Автор: frenkys 20.3.2006, 19:15
Всем спасибо вопросс решен

надо было инфу в реестр добавить о расширении .fpl

Автор: YURIC 20.8.2006, 11:48
Apache/2.0.59 (Win32) PHP/5.1.4 mod_fastcgi/2.4.2 mod_perl/2.0.2 Perl/v5.8.8

Стучи: 913555

Добавлено @ 11:49 
Сорри не дочител до конца smile

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)