| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Delphi: Общие вопросы > FastReport сервер |
| Автор: Ann Ivanova 22.6.2004, 12:58 |
| Сервер FastReport обеспечивает множество возможностей для удаленной генерации отчетов в сетях Интернет и интранет. Построение отчетов осуществляется с помощью генератора FastReport версии 3. Для обмена информации между клиентом и сервером использован HTTP протокол (RFC 2068). Сервер FastReport полностью автономный и не требует применения других HTTP серверов (Apache, IIS и др.), хотя может работать совместно с любым из них. Применение: Построение отчетов в сетях Internet/intranet Web-разработка Конечные решения для аналитических, финансовых, кадровых приложений для малого и большого бизнеса как часть систем управления предприятием Любые промышленные решения, базирующиеся на технологии клиент-сервер. Планируемые возможности: Полная совместимость с FastReport 3 Совместимость с протоколом HTTP (RFC 2616) Использование в качестве автономного web-сервера Авторизация доступа к серверу на основе групп и прав пользователей Использование сжатия Gzip (RFC 1952) для обмена данными между клиентом и сервером Реализация технологии SSI для динамического включения других HTML страниц Клиентский модуль для доступа к серверу из приложения для многих платформ разработки Доступ к серверу из любого web-браузера Поддержка выходных форматов: PDF, XML, Jpeg, RTF, HTML Удаленный доступ администратора к панели управления сервером Ведение протоколов функционирования и доступа к серверу Поддержка HTML форм Генерация HTML форм на основе форм FastReport на лету в процессе генерации отчета для интерактивного обмена информацией с пользователем Доступ к нескольким типам СУБД Одновременный доступ к нескольким СУБД Печать на сетевых принтерах (поддержка матричных принтеров) Поддержка многопроцессорных систем Подробнее на: http://www.fastreports.net/en/server.php FastReport Server on-line demo: http://fastreports.net/server P.S.: Не забудьте проголосовать за FastReport на The Delphi Informant 2004 Reader's Choice Award http://www.delphizine.com/ballot2004/ -- С наилучшими пожеланиями, Michael Philippenko mailto:info@fast-report.com Fast Reports - cross-platform multi-language solutions for developers http://www.fast-report.com http://www.fastexperts.com |