| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Java EE (J2EE) и Spring > run HelloWorld servlet by Jetty |
| Автор: _ren_ 9.5.2007, 18:19 | ||||
| Привет. Вопрос новичка. Взял пример простейшего сервлета:
Захотел запустить это дело под Jetty-6.1.0. Посмотрел README.txt у Jetty: "Jetty depends ONLY on a jre 1.4 runtime and the three jars found in the top level of the $JETTY_HOME/lib directory: servlet-api-2.5-$VERSION.jar jetty-$VERSION.jar jetty-util-$VERSION.jar" Соответственно, собрал класс TestServlet с подключением библиотек servlet-api-2.5.jar и rt.jar из jre 1.4. Поместил TestServlet.class в \jetty-6.1.0\webapps\test\WEB-INF\classes\com\acme\ Добавил в \jetty-6.1.0\webapps\test\WEB-INF\web.xml новые данные:
Запустил Jetty и получил в ответ пакет ругани, начинающийся с: Error starting handlers java.lang.NoClassDefFoundError: com/acme/TestServlet (wrong name TestServlet) После этого Jetty перестала "видеть" и предустановленные сервлеты-примеры, выдавая ERROR 404 на обращение к http://localhost:8080/ Был бы благодарен за подсказку: в чём здесь может быть загвоздка. Спасибо. |
| Автор: Stampede 9.5.2007, 18:30 | ||
_ren_, чтобы твой класс TestServlet распознавался под полным именем com.acme.TestServlet, недостаточно просто поместить его в директорию com/acme. Надо еще в исходнике прописать название пакета. Первой строчкой пишешь:
В остальном все вроде нормально. ЗЫ. Пользуйся подсветкой синтаксиса (кнопка "Код") - так гораздо удобнеее читать. |
| Автор: _ren_ 9.5.2007, 19:34 |
| Stampede, спасибо за совет! Jetty ругаться перестала. Но по-прежнему игнорирует новый сервлет, несмотря на то, что код у него тот же, что и в предустановленном у Jetty сервлете HelloWorld (лишь названия и url-pattern разные) - задача пока просто оживить тот же код самостоятельно. |
| Автор: Stampede 9.5.2007, 20:04 |
Какой адрес вводишь в адресной строке браузера и что видишь в окне? |
| Автор: _ren_ 9.5.2007, 20:11 |
| > Какой адрес http://localhost:8080/hi/ В браузере: HTTP ERROR: 404 NOT_FOUND RequestURI=/hi/ Powered by jetty:// |
| Автор: Stampede 9.5.2007, 20:24 |
| Должен быть такой: http://localhost:8080/test/hi/ Это потому что все приложение развернуто под webapps/test |
| Автор: _ren_ 9.5.2007, 20:50 |
| |
| Автор: v2v 29.6.2007, 10:21 | ||||
Как я понял при создании каждого нового сервлета надо добавлять такой кусок кода, а нет каких то автоматических средств, что делали бы это сами? (Сервер Tomcat) |
| Автор: v2v 1.7.2007, 19:59 |
| не юзаю ide. пыаюся все нюансы разобрать вручную... |