Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Java EE (J2EE) и Spring > глюк NetBeans IDE 6.0 RC2 или я тупой


Автор: xber9 31.1.2008, 18:38
создал в NetBeans IDE 6.0 RC2   web application
при создании выбрал все что есть и visual web  и тд
запускаю пустой проект
 он мне выдае ошибку
ошибка самого проекта
Код

init:
deps-module-jar:
deps-ear-jar:
deps-jar:
Created dir: D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\classes
Created dir: D:\NetBeansProjects\WebApplication6\build\web\META-INF
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\META-INF
Copying 12 files to D:\NetBeansProjects\WebApplication6\build\web
library-inclusion-in-archive:
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
Copying 1 file to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\lib
library-inclusion-in-manifest:
Compiling 4 source files to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\classes
Copying 2 files to D:\NetBeansProjects\WebApplication6\build\web\WEB-INF\classes
compile:
compile-jsps:
Starting Tomcat process...
Waiting for Tomcat...
Tomcat server started.
In-place deployment at D:\NetBeansProjects\WebApplication6\build\web
Deployment is in progress...
deploy?config=file:/C:/DOCUME~1/xber9/LOCALS~1/Temp/context21254.xml&path=/WebApplication6
http://localhost:8084/manager/deploy?config=file:/C:/DOCUME~1/xber9/LOCALS~1/Temp/context21254.xml&path=/WebApplication6
Deployment error:
The module has not been deployed.
See the server log for details.
        at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:163)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:104)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor102.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:357)
        at org.apache.tools.ant.Target.performTasks(Target.java:385)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
        at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:277)
        at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:460)
        at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
Caused by: The module has not been deployed.
        at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:157)
        ... 16 more
BUILD FAILED (total time: 1 minute 6 seconds)



а вот  лог томкета
Код

Using CATALINA_BASE:   C:\Documents and Settings\xber9\.netbeans\6.0rc2\apache-tomcat-6.0.14_base
Using CATALINA_HOME:   C:\Program Files\Apache Software Foundation\Apache Tomcat 6.0.14
Using CATALINA_TMPDIR: C:\Documents and Settings\xber9\.netbeans\6.0rc2\apache-tomcat-6.0.14_base\temp
Using JRE_HOME:        C:\Program Files\Java\jdk1.6.0_03
31.01.2008 18:33:14 org.apache.catalina.core.AprLifecycleListener init
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.6.0_03\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;D:\site\PHP\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;D:\site\MySQL\bin
31.01.2008 18:33:14 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8084
31.01.2008 18:33:14 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1343 ms
31.01.2008 18:33:14 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
31.01.2008 18:33:14 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.14
31.01.2008 18:33:15 org.apache.tomcat.util.digester.Digester fatalError
SEVERE: Parse Fatal Error at line 1141 column 1: Content is not allowed in trailing section.
org.xml.sax.SAXParseException: Content is not allowed in trailing section.
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
        at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
        at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1411)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$TrailingMiscDriver.next(XMLDocumentScannerImpl.java:1430)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:645)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:508)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
        at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1562)
        at org.apache.catalina.startup.ContextConfig.processDefaultWebConfig(ContextConfig.java:695)
        at org.apache.catalina.startup.ContextConfig.defaultWebConfig(ContextConfig.java:632)
        at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1061)
        at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4239)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
        at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)
        at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at org.apache.catalina.core.StandardService.start(StandardService.java:516)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:566)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
31.01.2008 18:33:15 org.apache.catalina.startup.ContextConfig processDefaultWebConfig
SEVERE: Parse error in default web.xml
org.xml.sax.SAXParseException: Content is not allowed in trailing section.
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1231)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
        at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1562)
        at org.apache.catalina.startup.ContextConfig.processDefaultWebConfig(ContextConfig.java:695)
        at org.apache.catalina.startup.ContextConfig.defaultWebConfig(ContextConfig.java:632)
        at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1061)
        at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4239)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
        at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)
        at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at org.apache.catalina.core.StandardService.start(StandardService.java:516)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:566)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
31.01.2008 18:33:15 org.apache.catalina.startup.ContextConfig processDefaultWebConfig
SEVERE: Occurred at line 1141 column 1
31.01.2008 18:33:15 org.apache.catalina.startup.ContextConfig start
SEVERE: Marking this application unavailable due to previous error(s)
31.01.2008 18:33:15 org.apache.catalina.core.StandardContext start
SEVERE: Error getConfigured
31.01.2008 18:33:15 org.apache.catalina.core.StandardContext start
SEVERE: Context [/manager] startup failed due to previous errors
31.01.2008 18:33:16 org.apache.tomcat.util.digester.Digester fatalError
SEVERE: Parse Fatal Error at line 1141 column 1: Content is not allowed in trailing section.
org.xml.sax.SAXParseException: Content is not allowed in trailing section.
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
        at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
        at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1411)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$TrailingMiscDriver.next(XMLDocumentScannerImpl.java:1430)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:645)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:508)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
        at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1562)
        at org.apache.catalina.startup.ContextConfig.processDefaultWebConfig(ContextConfig.java:695)
        at org.apache.catalina.startup.ContextConfig.defaultWebConfig(ContextConfig.java:632)
        at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1061)
        at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4239)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
        at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)
        at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at org.apache.catalina.core.StandardService.start(StandardService.java:516)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:566)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
31.01.2008 18:33:16 org.apache.catalina.startup.ContextConfig processDefaultWebConfig
SEVERE: Parse error in default web.xml
org.xml.sax.SAXParseException: Content is not allowed in trailing section.
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1231)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
        at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1562)
        at org.apache.catalina.startup.ContextConfig.processDefaultWebConfig(ContextConfig.java:695)
        at org.apache.catalina.startup.ContextConfig.defaultWebConfig(ContextConfig.java:632)
        at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1061)
        at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4239)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
        at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)
        at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at org.apache.catalina.core.StandardService.start(StandardService.java:516)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:566)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
31.01.2008 18:33:16 org.apache.catalina.startup.ContextConfig processDefaultWebConfig
SEVERE: Occurred at line 1141 column 1
31.01.2008 18:33:16 org.apache.catalina.startup.ContextConfig start
SEVERE: Marking this application unavailable due to previous error(s)
31.01.2008 18:33:16 org.apache.catalina.core.StandardContext start
SEVERE: Error getConfigured
31.01.2008 18:33:16 org.apache.catalina.core.StandardContext start
SEVERE: Context [] startup failed due to previous errors
31.01.2008 18:33:16 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8084
31.01.2008 18:33:16 org.apache.jk.common.ChannelSocket init
INFO: Port busy 8009 java.net.BindException: Address already in use: JVM_Bind
31.01.2008 18:33:16 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8010
31.01.2008 18:33:16 org.apache.jk.server.JkMain start
INFO: Jk running ID=1 time=0/78  config=null
31.01.2008 18:33:16 org.apache.catalina.startup.Catalina start
INFO: Server startup in 2254 ms


как заставить работать не знаю

Автор: Zamuta 31.1.2008, 20:25
xber9, Попробуй последнюю версию, зачем тебе RC2?

Автор: Greg 1.2.2008, 00:17
Похоже один из файлов 
  •  C:\Documents and Settings\xber9\.netbeans\6.0rc2\apache-tomcat-6.0.14_base\conf\web.xml
  •  C:\Program Files\Apache Software Foundation\Apache Tomcat 6.0.14\conf\web.xml
не валидный, скорее всего первый.

Автор: xber9 1.2.2008, 00:18
так это помоему и есть последняя

Автор: Greg 1.2.2008, 00:21
Цитата(xber9 @  1.2.2008,  00:18 Найти цитируемый пост)
так это помоему и есть последняя 

Имелось ввиду последнюю стабильную версию, RC - Release Candidate.

Автор: xber9 1.2.2008, 11:35
Цитата(Greg @  1.2.2008,  00:17 Найти цитируемый пост)
Похоже один из файлов 
 C:\Documents and Settings\xber9\.netbeans\6.0rc2\apache-tomcat-6.0.14_base\conf\web.xml
 C:\Program Files\Apache Software Foundation\Apache Tomcat 6.0.14\conf\web.xml

не валидный, скорее всего первый. 


ну а что делоть

Автор: Greg 1.2.2008, 11:41
Для начала покажи оба файла, а там посмотрим.

Автор: xber9 2.2.2008, 00:39
вот http://xber9.narod.ru/DS/web.xml
  и вот http://xber9.narod.ru/DS/web2.xml

Добавлено через 39 секунд
помогите

Автор: Greg 2.2.2008, 00:53
В первом файле удали строки 1141-1144.

Автор: xber9 2.2.2008, 14:31
работает урааа
только вот откуда это лишний фрагмент мог взяться? как думаете?

Автор: Greg 2.2.2008, 14:39
Что бы таких вопросов не было, нужно использовать стабильную версию, но не RC.
Используешь RC - будь готов ко всему. RC - означает, что весь функционал уже написан, но до выпуска релиза должно пройти некторое время, за которое исправятся баги и, возможно, появятся некоторые мелкие доработки. 

Автор: xber9 2.2.2008, 14:47
мммммм ок бсь большеоое

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)