| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Java EE (J2EE) и Spring > log4j+hibernate ошибка инициализации |
| Автор: iluvatar 14.10.2008, 12:06 | ||||
| tomcat, hibernate, log4j среда - NetBeans 6.1 log4j.xml:
после того как к проекту подключил hibernate выдает вот такую ошибку:
я же указал аппендер hibernateFileout. Что я делаю не так? |
| Автор: necromancer 14.10.2008, 13:19 |
| ну он же тебе написал: More Information: xmlns is reserved может стоит поменять строчку: xmlns:log4j="http://jakarta.apache.org/log4j/" на например: xmlns:log4j="http://jakarta.apache.org/log4j/my/" хотя конечно корень проблемы может быть далеко не тут. Лично я пользуюсь не xml конфигурацией log4j |
| Автор: iluvatar 14.10.2008, 14:26 |
| нет, проблема не в этом. до подключения hibernate он работчал отлично. |
| Автор: necromancer 14.10.2008, 14:32 |
| как раз может и в этом, хибернат может где либо использовать данный нем спейс =) |
| Автор: iluvatar 14.10.2008, 14:58 |
| На всякий случай проверил, ошибки те же |
| Автор: necromancer 14.10.2008, 15:54 |
| http://forums.sun.com/thread.jspa?threadID=663696&tstart=90 |
| Автор: iluvatar 14.10.2008, 16:34 |
| По ссылке предложен только один рабочий вариант - использовать другой xml парсер. Как это заюзать? |
| Автор: necromancer 14.10.2008, 17:06 |
| а отказатся совсем от конфигурации log4j через xml нет возможности? |
| Автор: iluvatar 14.10.2008, 20:02 |
| )) Это не наши методы. Хотя, если уж совсем никак не получится, то придется |
| Автор: iluvatar 23.10.2008, 11:38 |
| теме ап! |
| Автор: LSD 23.10.2008, 11:56 |
| Нафига вообще указывать неймспейс при использовании DTD? |
| Автор: iluvatar 23.10.2008, 12:10 | ||||
| Простите, не понял. Можете показать как должен выглядеть log4j.xml Сейчас попробовал использовать log4j.properties:
написал листенер:
Если я неправильно напишу конфиг (напр. не укажу аппендер для класса в котором используется Logger), то мне немедленно будет сказано об этом в логах томката. Если конфиг правильный, то он просто не создает файлов и игнорирует мои вызовы logger.errror, logger.debug и т.д. |
| Автор: LSD 24.10.2008, 11:17 | ||||
| Я про xmlns - это объявление неймспейса. Сделай так:
или даже так:
|
| Автор: iluvatar 28.10.2008, 11:01 | ||||||||
| Не спасло. С такой кофигурацией
.... пишет
а с таким кофигом
падает ошибка
Вывод: второй вариант не подходит вообще. В первом непонятно почему падает ошибка gnu.xml.dom.DomEx: The operation violates XML Namespaces. More Information: xmlns is reserved |
| Автор: ivg 28.10.2008, 11:51 |
| А откуда у вас gnu.xml.** пакеты взялись? Попробуйте сделать так, чтобы загрузчик классов их не находил... |
| Автор: iluvatar 30.10.2008, 10:56 |
| Спасибо. Действительно, после удаления лишних библиотек, все заработало. |