Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Java EE (J2EE) и Spring > Использование ресурсов


Автор: Vyacheslav32 9.3.2020, 19:43
Добрый день.

ОS - Solaris
Сервер приложений Jboss 4.3

Не могу понять как загрузить ресурс из папки расположенной вне проекта.

папка с ресурсами /opt/song/sound1.mp3
папка с проектом /opt/JBOSS/project/

Обращение к ресурсу выполнено в JSP в секции javascript ...

Код

var path = '/opt/song/';
player.src = path + 'sound1.mp3';

 
При попытке обратиться к ресурсу из папки /opt/song/ 
получаю HTTP Error 404. The requested resource is not found.

А на windows все отлично находится и проигрывается

Подскажите в чем может быть проблема






Автор: Bulat 10.3.2020, 09:14
Цитата(Vyacheslav32 @  9.3.2020,  19:43 Найти цитируемый пост)
А на windows все отлично находится и проигрывается


Цитата(Vyacheslav32 @  9.3.2020,  19:43 Найти цитируемый пост)
ОS - Solaris


еще пояснения нужны?  smile 

Автор: Vyacheslav32 10.3.2020, 23:01
Да, я не разобрался.

Автор: Bulat 11.3.2020, 14:39
Цитата(Vyacheslav32 @  10.3.2020,  23:01 Найти цитируемый пост)
Да, я не разобрался.

права доступа у пользователя какие? у директорий какие?

Автор: Vyacheslav32 11.3.2020, 18:05
rwxr-xr-x

Автор: Bulat 12.3.2020, 11:16
Цитата(Vyacheslav32 @  11.3.2020,  18:05 Найти цитируемый пост)
rwxr-xr-x

а конкретнее? эти чьи права описаны?

Автор: Vyacheslav32 12.3.2020, 12:42
папка с ресурсами /opt/song/sound1.mp3
каталог opt - rwxr-xr-x
каталог song - rwxr-xr-x
файл sound1.mp3 - rwxrwxrwx

opt/JBOSS/project
каталог opt - - rwxr-xr-x
каталог JBOSS - - rwxr-xr-x

       

Автор: Bulat 12.3.2020, 16:27
Цитата(Vyacheslav32 @  9.3.2020,  19:43 Найти цитируемый пост)
При попытке обратиться к ресурсу из папки /opt/song/ 
получаю HTTP Error 404. The requested resource is not found.

У тебя это пишет веб-сервер? А в качестве веб-сервера что используется?

Автор: Vyacheslav32 12.3.2020, 17:39
1. WebServer - Jboss 4.3
2. Ошибку получаю не в логах jboss, а в консоли хрома.

В плеер, находящийся на странице, должен подставиться трек и начать автоматическое проигрывание, но этого не происходит. 
в консоли наблюдаю ошибку:

Failed to load resource: the server responded with a status of 404 (/opt/song/sound1.mp3)

Автор: Bulat 13.3.2020, 08:45
Цитата(Vyacheslav32 @  12.3.2020,  17:39 Найти цитируемый пост)
2. Ошибку получаю не в логах jboss, а в консоли хрома.

В консоль хрома ошибка попадает из веб-сервера!

Надо разбираться почему веб-сервер не видит этот файл. Причина как минимум в этом(допускаю, что могут быть еще баги). Но в JBoss лично я не силен.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)