Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > .htaccess - Двойной запрет?


Автор: asg 2.1.2007, 14:20
В локальной сети один сайт. Сайт запрещён для интернета и разрешён для диапазона сетевых айпишников.

deny from all
allow from 194.67.139. 10.10.


Нужно плюс к этому поставить запрет на один или несколько сетевых айпишников (к примеру 10.10.30.29). Но как?

Подскажите пожалуйста. 

Автор: Mal Hack 2.1.2007, 14:37
Я думаю, ты найдешь ответ тут: http://httpd.apache.org/docs/2.0/mod/mod_access.html

Автор: asg 2.1.2007, 15:20
неработает. Пробывал по всякому.

Пробывал запрещать свой ип (зона которого разрешена), но всёравно могу заходить на сайт.

Order Deny,Allow
Allow from 213.251.198.  //Зона моего ипа
Allow from 10.10.
Deny from all
Deny from 213.251.198.55   // Мой ип

Автор: Mal Hack 2.1.2007, 15:25
asg, ты обрати внимание на директиву Order и почитай что про нее там написано.

Автор: asg 2.1.2007, 17:39
Да даже без Order неработает.... ((

Вы немогли бы привести конкретный пример. Когда разрешены только несколько зон ип адресов, а остальное ВСЁ запрещено + запрещён ещё один(или несколько ип адресов) зона которых входит в разрешённую.

Автор: Mal Hack 2.1.2007, 17:57
Код

Order Allow, Deny
Allow 10.10
Deny 10.10.30.29

Автор: asg 2.1.2007, 21:21
А пользователи других зон и интернета смогут зайти на сайт? Там же запрет стоит только на конкретный ип а не Deny from all

Автор: Mal Hack 2.1.2007, 22:48
asg, я же говорил, внимательно прочитай про Order.

Цитата
Allow,Deny
    The Allow directives are evaluated before the Deny directives. Access is denied by default. Any client which does not match an Allow directive or does match a Deny directive will be denied access to the server.


Вроде бы все понятно написано...

Автор: asg 3.1.2007, 00:34
Order Allow, Deny
Allow 10.10
Deny 10.10.30.29

Вызывает Ошибку сервера. Код ошибки  - 500

Автор: Mal Hack 3.1.2007, 02:15
Код

Order Allow,Deny
Allow 10.10
Deny 10.10.30.29

Автор: asg 3.1.2007, 14:46
Всёравно ошибка 500, пробывал на двух серверах 

Автор: Mal Hack 3.1.2007, 15:21
asg, до чего лень доводит. Ну неужели сложно понять, что я чисто случайно from пропустил...
Код
Order Allow,Deny
Allow from 10.10
Deny from 10.10.30.29

Автор: asg 3.1.2007, 15:25
Большое спасибо smile

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)