Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > IIS6 и работа PHP через CGI


Автор: Верлиока 10.9.2007, 17:26
Дано:
Windows 2003 Server SP2 + IIS6
Установлен PHP 5.1.3 (хотя не важно, с 5.2.3/5.2.4 такая же проблема)


Необходимо установить в IIS6 поддержку PHP через CGI


Права на запуск из папки, куда установлен PHP, - есть.

В настройке веб-приложения добавлено Сопоставление:
 Исполняемый файл: путь на php-cgi.exe
 Расширение: .php
 Все команды ON
 Обработчик сценариев ON
 Проверка наличия файла ON 

В настройках IIS в разделе Расширения веб-службы добавлено расширение PHP, в котором указан путь на php-cgi.exe

В настройках виртуального веб-сервера  опция Разрешен запуск: Только сценарии.

 
При обращении к любому php-скрипту из браузера получаем:
HTTP Error 403 - Forbidden: Access is denied.

Как быть?

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)