Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > обработчик ASPX в IIS 7.0


Автор: STRELOKBMSTU 27.1.2008, 01:30
Народ, подскажите, как правильно настроить IIS 7.0 (Windows Vista). Когда я создал виртуальную директорию, по умолчанию файлы в ней типа *.ASPX обрабатываются статическим обрабочиком (а так как MIME для ASPX отсутствует, то и страница не отображается). Какой обработчик необходимо использовать, чтобы старицы отображались корректно???

Автор: Mymik 27.1.2008, 14:18
запусти
Код

c:\WINDOWS\Microsoft.NET\Framework\<Версия .NET Framework>\aspnet_regiis.exe -i 

и тебе будет счастье smile

Автор: lando1 28.1.2008, 18:48
а если это не помогло?;)

Автор: Mymik 28.1.2008, 19:43
ну а если не помогло... тогда тебе надо подвешивать обработку расширения .aspx на aspnet_isapi.dll (кажется smile я точно не помню, сейчас дома а тут ни IIS, ни Visual Studio нет, завтра посмотрю более подробно smile)

Модератор: Перемещено из раздела http://forum.vingrad.ru/forum/dotnet-asp-net.html

Автор: lando1 30.1.2008, 10:33
помогло следующее - открыл из VS 2005 проект, который уже был задеплоен на IIS - при это студия ругнулась на то, что у IIS'а не включена поддержка asp и предложила ее включить. После этого все заработало.

Автор: STRELOKBMSTU 31.1.2008, 04:36
В общем, сделал regiis, добавились обработчики. Попытался запустить страницу, ей не понравился пул приложения, она попросила Classiс .NET AppPool, добавил его следующей командой - AppCMD.exe set app "Default Web Site/" /applicationPool:"Classic .NET AppPool"
Теперь возникла другая проблема, он ругается на обработчик, который я раньше сам создавал(ASPX).

Код

Ошибка сервера в приложении "Default Web Site"
HTTP Error 500.0 - Internal Server Error

Описание: Обработчик "ASPX" содержит поврежденный модуль "ManagedPipelineHandler" в списке модулей 

Код ошибки: 0x8007000d 

Уведомление: ExecuteRequestHandler 

Модуль: IIS Web Core 

Запрашиваемый URL-адрес: http://localhost/J/Default.aspx 

Физический путь: C:\inetpub\wwwroot\J\Default.aspx 

Вход пользователя: Анонимная 

Способ входа: Анонимная 

Обработчик: ASPX 

Наиболее вероятные причины: 
\t
Модуль указан в конфигурации, однако он не был установлен или его имя указано неверно.
\t
Службы IIS получили запрос; однако при обработке запроса произошла внутренняя ошибка. Причина этой ошибки зависит от от того, какой модуль обрабатывает запросы и какие процессы имели место в рабочем процессе при возникновении этой ошибки.
\t
Службы IIS не смогли получить доступ к файлу web.config веб-узла или приложения. Это может произойти, если разрешения NTFS установлены неправильно.
\t
Службы IIS не смогли обработать конфигурацию веб-узла или приложения.
\t
Прошедший проверку пользователь не имеет разрешений на использование этой библиотеки DLL.

Что можно предпринять: 
\t
Проверьте, установлен ли модуль. Описание ошибки может содержать дополнительные сведения, помогающие определить источник ошибки.
\t
Если модуль установлен, проверьте правильность написания его имени в разделе конфигурации configuration/system.webServer/handlers config.
\t
Убедитесь, что установлены верные разрешения NTFS для файла web.config, разрешающие доступ к учетной записи компьютера веб-сервера.
\t
Проверьте журналы событий, чтобы посмотреть, были ли зафиксированы какие-либо дополнительные сведения.
\t
Проверьте разрешения на использование библиотеки DLL.
\t
Создайте правило трассировки, чтобы отслеживать невыполненные запросы для этого кода состояния HTTP. Чтобы получить дополнительные сведения о создании правила трассировки для невыполненных запросов, щелкните здесь. 

Дополнительные сведения... Эта ошибка означает, что при обработке запроса возникла неполадка. Запрос был получен веб-сервером, но при его обработке возникла неустранимая ошибка, которая привела к ошибке 500. 

Статьи базы знаний Microsoft Knowledge Base: 
Версия сервера: IIS 7.0.


Но, ни модуля ManagedPipelineHandler ни обработчика ASPX уже нету! Может кто подсказать, как решить эту проблему??? Где находится этот самый handlers.config??? Какой XML-ник нужно исправить, чтобы устранить эту ошибку?

Автор: Rate93 24.9.2008, 11:29
Цитата(lando1 @ 30.1.2008,  10:33)
помогло следующее - открыл из VS 2005 проект, который уже был задеплоен на IIS - при это студия ругнулась на то, что у IIS'а не включена поддержка asp и предложила ее включить. После этого все заработало.

Такая же ситуация! Только не могу открыть сайт в VS так чтобы вылетело предложение о включении ASP.NET.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)