Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > ЧПУ и mod_rewrite


Автор: Nuss 20.3.2008, 01:47
Доброго времени суток!
Проблема возникла там, где ее никто не ждал. На хостинге ЧПУ работает корректно, если файл не найден, то переходим в файлу-анализатору и все чики-брики. Теперь понадобилось на локальном компе настроить такую же штуку:
- mod_rewrite подключен

- содержимое файла .htaccess
Код

RemoveHandler .htm
AddType application/x-httpd-php .htm

Options +FollowSymlinks
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ script.phtml [L,QSA] 


- файл-анализатор содержит в себе
Код

<?php
$arr = explode('/', $_SERVER['REQUEST_URI']);

echo '<pre>';
print_r ($arr);
echo '</pre>';
?>


При запросе не существующего файла выдается сообщение: The requested URL /_list/client/1.htm was not found on this server.
В логах следующие записи:
127.0.0.1 - - [20/Mar/2008:01:44:55 +0300] "GET /_list/client.htm HTTP/1.1" 200 2435
127.0.0.1 - - [20/Mar/2008:01:44:59 +0300] "GET /_list/client/1.htm HTTP/1.1" 404 300

[Thu Mar 20 01:44:59 2008] [error] [client 127.0.0.1] File does not exist: C:/iProject/Apache Group/Apache2/htdocs/_list/client, referer: http://localhost/_list/client.htm

Помогите, пожалуйста, определить причину ошибки.

p.s. RewriteRule в файле httpd.conf не встречается

Автор: Nuss 25.3.2008, 12:43
Проблема решилась добавлением следующих строк в .htaccess:

Код


RewriteEngine On
RewriteBase /


Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)