| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Администрирование Web серверов и Web служб > Удалить ERROR_LOG уапача |
| Автор: abalich 8.5.2008, 09:19 |
| Здрасте. Как запретить писать Апачу error_log в /etc/httpd т.к. он за ночь вырастает до 10 ГБ. ? |
| Автор: Сумасшедший 8.5.2008, 11:01 |
| abalich, отключить лог ошибок? настроить logrotate (newsyslog)? |
| Автор: abalich 8.5.2008, 11:57 |
| Сумасшедший, отключить лог ошибок. |
| Автор: Сумасшедший 8.5.2008, 12:59 |
| abalich, в конфиге апача найдите строку, в которой прописывается путь к логу и закомментируйте её. Перезапустите апач. Готово |
| Автор: abalich 8.5.2008, 15:02 |
| Сумасшедший, нешёл, закоментрировал, лог поначалу не появлялся. Но через 4 часа снова возник с весом 15 ГБ. Он находится в /etc/httpd/error_log там записи типа [Thu May 08 12:58:04 2008] [error] [client 193.200.50.225] PHP Notice: Only variable references should be returned by reference in /home/divnogor.ru/cms/core/template/compiler/source_file_parser.class.php on line 407, referer: http://info.tikiwiki.org/tiki-view_tracker.php?status=o&trackerId=1&offset=0&sort_mode=f_4_asc, http://www.weishi.com/newsd |
| Автор: abalich 8.5.2008, 16:30 |
| Сумасшедший, точно это PHP логи. Как их вырубить ? |
| Автор: ZeeLax 8.5.2008, 18:11 |
| abalich, сходите в кофиг пхп. Там для этого есть отдельная секция с комментариями. P.S. А ещё лучше - исправить ошибку в коде. |
| Автор: Feldmarschall 8.5.2008, 19:00 |
| Жесть. вместо того, чтобы устранить причину ошибки, отключать логи =) |
| Автор: Сумасшедший 12.5.2008, 09:25 | ||
К несчастью, таких много=( |
| Автор: abalich 12.5.2008, 10:45 |
| Ошибку исправить будет проблематично. Т.к. Это движок LIMB причем он ошибку выпуливает только на моем серваке. На других ошибки нету. Движок весь переписывать ? Я один раз загружу сайт. ТАк он 500 строк добавляет в лог. ПРичем из 30 разных файлов. |
| Автор: Сумасшедший 12.5.2008, 12:17 |
| Костылизм |