Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > Взгромаздил апач, а он........!


Автор: -=Ustas=- 4.8.2005, 10:30
Мое почтение!
Скажите, что это может быть! При установке, перед самым финишем появляется командное окошко, в котором появляется эта ругань :
Цитата
(OS 10048)+?v??? ?????°????  ???? ????????????? ?????? ?????? (????????/???????
?????/????).  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Затем, после финиша, пробую пускать его, но выскакивает точно такая же лажа! Что делать подскажите! У меня ХРюша СП1, Апач 2.0.54.
smile

Автор: Akina 4.8.2005, 11:29
Установленные приложения вообще-то принято настраивать. Применительно к данному случаю - параметр Listen глобальной секции в файле httpd.conf

Автор: Styler 4.8.2005, 13:15
Akina у него ошибка появляется еще на этапе установки.

-=Ustas=- у меня было такое когдя я ставил Апач на компьютере на котором не было нр локальной сети ни модема. Выкрутился из проблемы простой установкой контроллера удаленнного доступа.

Автор: Akina 4.8.2005, 13:22
Цитата(Styler @ 4.8.2005, 14:15)
у него ошибка появляется еще на этапе установки

Неверно. Последний этап установки - первичное конфигурирование. Именно оно сбоит. Приведенная тобой причина - одна из возможных. Решение тоже нормальное, хотя правильнее (именно в этом конкретном случае) ставить Microsoft Loopback adapter.

Автор: -=Ustas=- 4.8.2005, 13:31
Моя тачка находится в сравнительно небольшой локальной сети и на выделенке через прокси, если это имеет какое-то значение. Ставил себе "денвера", пашет только localhost, другие домены делал - они не хотят работать, хотя я для них создавал, так как и надо - виртуальные хосты и привязывал их в файле hosts. Что за муть такая?!

Автор: Mal Hack 4.8.2005, 14:08
Ты конфиг трогал?
По дефолту апач работает с 127.0.0.1, а у тебя нулевый UP, который даже в теории никуда тебя не приведетю
Цитата(Akina @ 4.8.2005, 12:29)
параметр Listen глобальной секции в файле httpd.conf


Автор: -=Ustas=- 4.8.2005, 15:04
Нет, еще не успел потрогать! smile Я же говорю, эта ошибка выскакивает еще в процессе установки. А в конфиге у меня localhost стоит.

Автор: Styler 5.8.2005, 12:43
-=Ustas=- - в случае с установкой Денвера тебе нужно было всего лишь создать нужные папки в директории /home и вовсе необязательно было трогать сам файл hosts - Денвер вносит в него коррективы автоматически.

Автор: -=Ustas=- 8.8.2005, 08:08
Цитата(Styler @ 5.8.2005, 12:43)
в случае с установкой Денвера тебе нужно было всего лишь создать нужные папки в директории /home и вовсе необязательно было трогать сам файл hosts - Денвер вносит в него коррективы автоматически.

При денвере я никакие файлы не трогал. Я же говорю, у меня выделенка, и когда я добавляю новый хост, то он лезет в нэт. Так что мен с апачем делать? Или это у меня операционка глючит?

Автор: -=Ustas=- 9.8.2005, 08:28
Что, я так понимаю, советы кончились...?!

Автор: Akina 9.8.2005, 08:42
Запусти тест httpd.conf - у тебя в нем ошибки. Исправь.

Автор: Moses 3.6.2006, 11:41
У меня возникли точно такие же проблемы. В командном окне то-же сообщение. Машина не подключена ни к локальной сети, ни к и-нету. 
В httpd.conf ошибок, на сколько я понимаю, нет. Если я умышленно делаю ошибку ближе к концу файла, то при повторной инсталляции (исправлении) Apache  в командном окне выдает сообщение Error в строке н-р 145. Если же исправить ошибку - выдает сообщение, приведенное автором данной темы. Кроме того, при инсталляции не создает log файлы. В папке logs только 1 файл - instal. 
Просьба советовать попроще. Я чайник в этом деле. По градации чайников - чайник 1-го порядка.
 

Автор: Сумасшедший 4.6.2006, 18:49
Так апач сообщает, что порт 80 на ip 0.0.0.0 используется другим процессом. Посмотри какие процессы слушают этот порт на таком ip. 

Автор: Moses 5.6.2006, 12:49
Разобрался. Просто Apache, установленный на работе, на компьютере, подключенном к локальной сети, ведет себя совсем по-другому. В моем случае - понадобилась просто перезагрузка. Спасибо. 

Автор: Cheba1 28.6.2006, 19:01
У меня проблема продолжается, после перезагрузки тоже все работате, но вот через 2-4 часа сново стопорится 80 порт...  Я в конфиге его убираю, - все работает... Но как тока я сново его прописываю - ничего не происходит.... И в логах как всегда ничего не записано...  Как я понял - надо искать прогу, которая грузит порт 80 - но такого я не нашол, если ставить другие версии апача, то без результатно, тоже самое происходит...  Мой вопрос в другом - как найти какая прога занимает порт 80....???? smile  

Автор: malor 7.8.2007, 21:55
Цитата
c:\WebServers\usr\local\Apache2\bin>apache.exe
[Tue Aug 07 21:54:31 2007] [error] (OS 11001)¦ЄюЄ їюёЄ эхшчтхёЄхэ.  : Cannot res
olve host name *.* --- ignoring!
(OS 10048)+сvўэю ЁрчЁх°рхЄё  юфэю шёяюы№чютрэшх рфЁхёр ёюъхЄр (яЁюЄюъюы/ёхЄхтющ
рфЁхё/яюЁЄ).  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Что делать?

Использую книгу "PHP 5 В подлиннике" Котеров&Костарев, 2006,BHV.
WinXP_Pre_sp3, apache_2.0.59-win32-x86-openssl-0.9.7j.msi

Автор: marykone 8.8.2007, 08:22
Цитата(-=Ustas=- @  4.8.2005,  13:31 Найти цитируемый пост)
Ставил себе "денвера"

вообщем лучшей сразу ставить apache

а вообще прислушайся что тебе говорят listen 80

вообще кинь httpd.conf люди посмотрят подскажут так проще чем гадать  

Автор: _GRIN_ 4.4.2009, 14:27
netstat -abn

Код

C:\Program Files\Apache Software Foundation\Apache2.2\bin>netstat -abn

Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       1072
  c:\windows\system32\WS2_32.dll
  C:\WINDOWS\system32\RPCRT4.dll
  c:\windows\system32\rpcss.dll
  C:\WINDOWS\system32\svchost.exe
  -- unknown component(s) --
  [svchost.exe]

  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
  [System]

  TCP    0.0.0.0:3306           0.0.0.0:0              LISTENING       1768
  [mysqld-nt.exe]

  TCP    127.0.0.1:80           0.0.0.0:0              LISTENING       1708
  [httpd.exe]

  TCP    127.0.0.1:30606        0.0.0.0:0              LISTENING       1700
  [ekrn.exe]

  TCP    192.168.1.4:139        0.0.0.0:0              LISTENING       4
  [System]

Автор: marykone 6.4.2009, 07:00
_GRIN_,  на дату посмотри ;) 

и создай новый топик что у тебя да как. 

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)