Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > *NIX системы: Общие вопросы > Ставлю новое ядро, ну и как принято Kernel panic


Автор: fuckerok 26.11.2004, 08:34
Вот недавно решил поставить себе 2.6.9 ядро..
Ставил так:
  • Всё настроил
  • make bzImage
  • make modules
  • make modules_install
  • make install
Ну думаю проблем с настройкай не должно быть, тк ставил по руководству и настраивал тоже...

Всё вроде нормально проставилось в grubconfig добавилось всё само...

Но вот когда хочу загрузить новое ядро у меня такая ошибка:
Цитата

VFS: cannot open root device "label=/" or unkown block(0,0)
please append a correct "root=" boot option
kernel panic - not syncing: VFS: unable to mount root fs on unkown block(0,0)


Что за хрень? И как это лечить?

Автор: Secandr 26.11.2004, 09:20
А что за ось?

Автор: dargaard 26.11.2004, 09:24
выведи свой /boot/grub/menu.lst


Там должна быть строчка из серии
title Red Hat linux (newone)
root (hd0,1)
kernel /bzImage ro root=LABEL=/ hdd=ide-scsi

посмотри правильно ли указивает root () и стоит ли root=LABEL=/

в root()-e первый параметр указывает на физический диск. второй на логический.

т.е. hd0,0 будет /dev/hda1
hd0,1 - /dev/hda2
hd1,0 - /dev/hdb1 и т.д.

Автор: fuckerok 27.11.2004, 05:49
вообщем вчера сам разобрался smile
Для рабочего ядра у меня в grubconfig стояло, что-то вроде
[quote]
.....
kernel /boot/vmlinuz-2.4-20 ro root=LABEL=/[/quote]
...

Для второго ядра которое я так упорно собирал стояло примерно тоже самое (только другая версия)

Ну дык я потом допёр, там ещё как коментариий в grubconfig Написанно...
Я делал так
[quote]
.....
kernel /boot/vmlinuz-2.6-9 ro root=hda5[/quote]
...[/quote]

И всё сразу заработало, конечно странно, что старое ядро грузилось, но вообщем всё заработало нормально smile

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)