| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Oracle > Нужно прочитать |
| Автор: Sax 29.4.2007, 20:07 |
| Дома используются: - Win XP SP2 rus; - Oracle 9i (9.2.0.1.0) Enterprise Edition; - Borland Delphi 7 Enterprise; - метод доступа - ADO (ADOTable). В корневом каталоге системного диска созданы папки "Новая папка", "Новая папка (2)", "Новая папка (3)". Из первой приложение запускается нормально и нормально работает. Из двух других уже при запуске пишет "ORA-06413: Соединение не открыто" с драйвером Microsoft OLE DB Provider for Oracle, а с драйвером Oracle Provider for OLE DB выдаёт ошибку "ORA-12154 TNS:невозможно разрешить имя службы". Попробовал создать папку со случайным именем "poiuyt" - рабоает, а с имененм "poiuyt (10)" - ошибки. Причём с именами "Новая папка 2", "Новая папка 3" всё работает. Причина непонятна, но ФАКТ!!! На это потребовалось две недели времени, более 7 раз переставлял Oracle, 1 переустановка Win и куча нервов! |
| Автор: TicTak 8.5.2007, 10:55 |
| Если немного присмотрется, то причина понятна, а именно символы "(" и ")". Видимо это запрещённые символы, правда какой частью... это сам. |
| Автор: Sax 12.5.2007, 14:18 |
| "Новая папка 2" - работает "Новая папка 3" - работает "Новая папка (2" - работает "Новая папка (3" - работает "Новая папка (2)" - не работает "Новая папка (3)" - не работает |
| Автор: TicTak 14.5.2007, 09:11 |
| А Новая папка 2) и Новая папка ()? |