Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Oracle > ORA-01031 при отправке логов на standby, help


Автор: neronov 24.5.2007, 08:00
Помогите разобратся. Пытаемся настроить стендбай на оракле 10.2, в самом конце при проверке в алерт.логе ошибка 

PING[ARC1]: Heartbeat failed to connect to standby 'stdby'. Error is 1031.
Thu May 24 10:59:51 2007
Error 1031 received logging on to the standby

В трейс файле 

*** 2007-05-24 10:59:51.546 61283 kcrr.c
Error 1031 received logging on to the standby
Error 1031 connecting to destination LOG_ARCHIVE_DEST_2 standby host 'stdby'
Error 1031 attaching to destination LOG_ARCHIVE_DEST_2 standby host 'stdby'
ORA-01031: insufficient privileges
*** 2007-05-24 10:59:51.546 61283 kcrr.c
PING[ARC1]: Heartbeat failed to connect to standby 'stdby'. Error is 1031.
*** 2007-05-24 10:59:51.546 59526 kcrr.c
kcrrfail: dest:2 err:1031 force:0 blast:1
*** 2007-05-24 11:04:51.690
Redo shipping client performing standby login
OCISessionBegin failed -1
.. Detailed OCI error val is 1031 and errmsg is 'ORA-01031: insufficient privileges

Хотя если через sqlplus соединяешся под sys - соединение проходит нормально. Пароли sys на обоих машинах одинаковые. Делали по http://www.adp-gmbh.ch/ora/data_guard/create_physical_standby_db.html и http://www.interface.ru/fset.asp?Url=/oracle/bd.htm. Обе машины в домене, служба оракла запущена под system (по умолчанию). Может быть из-за этого или нет? Просто остановить не могу, люди работают. Помогите!

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)