| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > MySQL > Не запускается MySQL Server под Linux |
| Автор: zluka 8.5.2007, 14:14 | ||||
| Здравствуйте. Установил MySQL 4.1 через .rpm. Пытаюсь запустить сервер командой:
На что отвечает:
В чем проблема? Помогите плз. З.Ы. ОС: ASPLinux 11 |
| Автор: Ignat 8.5.2007, 14:40 |
| Что-то подобное было, если нет системных таблиц. Нужно запустить mysqld с ключиком --skip-grant-tables и залить дамп системных таблиц. Дамп системных таблиц делает утилита с характерным названием (каким именно - не помню). |
| Автор: Бонифаций 8.5.2007, 16:13 |
| А в .err файле что написано? (это в каталоге с базами данных лежит файлик где должно быть поподробнее написано) |
| Автор: Бонифаций 9.5.2007, 00:34 |
| 1) Вы говорите что устанавливали из rpm, а файл запускаемый почему то в /usr/local ? У вас что, несколько инсталяций mysql на машине? 2)Судя по логу - mysql не запускается потому что не может найти свои системные таблицы - (host.frm) Одно из двух - или пользователю от имени которого запускается mysql не хватает прав даже читать каталог где данные или системных таблиц просто нет. PS. Или до этого mysql у вас стоял другой, и новый сервер подхватывает настройки старого |
| Автор: muzer 9.5.2007, 01:55 | ||
OS error code 13: Permission denied Запускайте от рута или от пользователя, у которого есть права на чтение директории ./mysql/ и файликов в ней (обычно это пользователь под именем mysql). Если не поможет, то обратите внимание на сообщение Ignat'а. |