Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > MySQL > Не запускается MySQL Server под Linux


Автор: zluka 8.5.2007, 14:14
Здравствуйте.
   Установил MySQL 4.1 через .rpm. Пытаюсь запустить сервер командой:
Код

[root@localhost zero_mod]# mysqld_safe &

На что отвечает:
Код

Starting mysqld daemon with databases from /var/lib/mysql
STOPPING server from pid file /var/run/mysqld/mysqld.pid
070508 13:53:07  mysqld ended

В чем проблема? Помогите плз.

З.Ы. ОС: ASPLinux 11

Автор: Ignat 8.5.2007, 14:40
Что-то подобное было, если нет системных таблиц.
Нужно запустить mysqld с ключиком --skip-grant-tables и залить дамп системных таблиц.
Дамп системных таблиц делает утилита с характерным названием (каким именно - не помню).

Автор: Бонифаций 8.5.2007, 16:13
А в .err файле что написано? (это в каталоге с базами данных лежит файлик где должно быть поподробнее написано) 

Автор: zluka 8.5.2007, 19:41
Цитата(Бонифаций @  8.5.2007,  16:13 Найти цитируемый пост)
А в .err файле что написано? (это в каталоге с базами данных лежит файлик где должно быть поподробнее написано)  

 Вот нашел какой-то localhost.err в каталоге /var/lib/mysql. Содержимое вот такое (это из последних записей):
Код

070508 19:26:48  mysqld started
070508 19:26:49  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
070508 19:26:49  InnoDB: Starting log scan based on checkpoint at
InnoDB: log sequence number 0 36808.
InnoDB: Doing recovery: scanned up to log sequence number 0 43655
070508 19:26:49  InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
InnoDB: Apply batch completed
070508 19:26:49  InnoDB: Started; log sequence number 0 43655
070508 19:26:49 [ERROR] /usr/local/libexec/mysqld: Can't find file: './mysql/host.frm' (errno: 13)
070508 19:26:49 [ERROR] /usr/local/libexec/mysqld: Can't find file: './mysql/host.frm' (errno: 13)
070508 19:26:49 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: './mysql/host.frm' (errno: 13)
070508 19:26:49  mysqld ended

Хотя, я мало что понял из написаного выше..

Автор: Бонифаций 9.5.2007, 00:34
1) Вы говорите что устанавливали из rpm, а файл запускаемый почему то в /usr/local ? У вас что, несколько инсталяций mysql на машине?

2)Судя  по логу - mysql не запускается потому что не может найти свои системные таблицы - (host.frm)
Одно из двух - 
  или пользователю от имени которого запускается mysql не хватает прав даже читать каталог где данные
  или системных таблиц просто нет.

PS. Или до этого mysql у вас стоял другой, и новый сервер подхватывает настройки старого



Автор: muzer 9.5.2007, 01:55
Цитата(zluka @  8.5.2007,  20:41 Найти цитируемый пост)
070508 19:26:49 [ERROR] /usr/local/libexec/mysqld: Can't find file: './mysql/host.frm' (errno: 13)
070508 19:26:49 [ERROR] /usr/local/libexec/mysqld: Can't find file: './mysql/host.frm' (errno: 13)

OS error code  13:  Permission denied

Запускайте от рута или от пользователя, у которого есть права на чтение директории ./mysql/ и файликов в ней (обычно это пользователь под именем mysql).

Если не поможет, то обратите внимание на сообщение Ignat'а.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)