Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > MySQL > Error 0


Автор: vikaz 25.4.2009, 13:37
Ребята, всем добрый день. Возникла сл. ситуация. Я себе поставил MySQL 5.0.1. И все работало нормально, но в определенный момент стал вылетать сервис, при этом в событиях писалось следующее:

Plugin 'InnoDB' init function returned error.
For more information, see Help and Support Center at http://www.mysql.com.  



Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
For more information, see Help and Support Center at http://www.mysql.com.  



Aborting
For more information, see Help and Support Center at http://www.mysql.com.  

Причем код ошибки у всех сообщений был одинаковый = 100.
Ну я не долго думая, решил переустановить сервер MySQL, но теперь не стартует сервис пишет:

Cannot create Windows service for MySQL501.Error:0

Если пытаюсь запустить его в ручную через службы и приложения система мне пишет:

Не удалось запустить службу MySQL501 на Локальный компьютер.
Ошибка 1067Ж процесс был неожиданно завершен.


Подскажите, в чем может быть проблема, впервые с таким столкнулся! :(
Заранее спасибо!!!!

Автор: skyboy 25.4.2009, 16:13
в интернетах искал(http://forums.mysql.com/read.php?11,11388,11388, http://www.board74.ru/articles/mysql/my.html)?

Автор: vikaz 25.4.2009, 16:49
Цитата(skyboy @  25.4.2009,  16:13 Найти цитируемый пост)
в интернетах искал(1, 2)? 

Спасибо! Решил проблему, в общем как обычно! Хорошо, что данных было немного!
Вот как решил: 
1. Удалил папку c:\Documents and Settings\All Users\Application Data\MySQL\
2. почистил реестр.
Все! smile Проблема решилась. Конечно не очень красивый метод, но повторюсь, данных было очень мало.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)