Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > MySQL > MySQL error 2003


Автор: carn 15.5.2012, 01:54
Люди, помоги исправить ошибку!
У при попытке подключения к базе данных вылетает ошибка 2003 Can't connect to localhost.
Я выполнил команду sc query MySQL.
Из ней узнал что сотояние MySQL STOPPED. 
Подскажите, пожалуйста, как мне его запустить?
С уважением, Виктор.

Автор: Akina 15.5.2012, 08:00
SC Start MySQL вероятно...

Автор: carn 15.5.2012, 08:44
нет, startService FAIL 3 при вводе этой команды

Автор: carn 15.5.2012, 09:08
я попробовал телнетом подконнектится к локалхост на 3306 - тоже не получается.

Автор: baldina 15.5.2012, 10:15
Цитата(carn @  15.5.2012,  09:08 Найти цитируемый пост)
я попробовал телнетом подконнектится к локалхост

кой смысл, если сервис остановлен
раз сервис не запускается, значит что-то с ним не в порядке.
проверьте его состояние
>sc qc MySQL
можно так же указать error.log при запуске сервиса

Автор: carn 15.5.2012, 10:31
Я проверял, он остановлен, а запустить то его как? )

Автор: carn 15.5.2012, 10:54
вот скрин... 

Автор: carn 15.5.2012, 10:55
могу ещё вот такое показать

Автор: baldina 15.5.2012, 15:10
Цитата(carn @  15.5.2012,  10:31 Найти цитируемый пост)
Я проверял, он остановлен, а запустить то его как? ) 

понятно, что он остановлен. понятно, что он не хочет запускаться. что-то не в порядке. нужно проверить конфигурацию. и проблемы, возникающие при запуске
Цитата(baldina @  15.5.2012,  10:15 Найти цитируемый пост)
проверьте его состояние
>sc qc MySQL
можно так же указать error.log при запуске сервиса 


попробуйте еще раз его сконфигурировать
>MySQLInstanceConfig.exe

Автор: carn 15.5.2012, 15:56
спасибо, проблема в том что MySQL Administrator очень устарел, и он неправильно мне сконфигурировал конфиг. Я откатился - всё норм. Всем спасибо!

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)