| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > MySQL > mysql_select_db |
| Автор: yulyaT 10.6.2012, 18:15 | ||||
| Пожалуйста помогите!!! На сайте freetzi.com создаю базку 12345, запускаю скрипт прямо на сайте на создание таблицы users, запускаю скрипт на заполнение insert into. ПРЯМО НА САЙТЕ такой select * from `users` проходит, всё как должно быть. Создаю файл db.php
Принт проходит: *****Resource id #2--------- А на mysql_select_db слетает Cant use:Access denied for user '12345'@'localhost' to database 'users' Замена кавычек 0х27 на двойную 0х22 в именах ничего не дает, также не помог вариант с кавычкой 0х60. Вариант
заканчивается тем же, т.е. коннект проходит, а подсоединение к таблице не проходит:( Помогите плс, с MySQL+PHP не приходилось работать, только с MSSQL+ASP. Заранее всем спасибо!! |
| Автор: ashain 10.6.2012, 19:51 |
| Судя по всему нет доступа для user'а с localhost'а. Попробуйте указать адрес сайта вместо localhost, учитывая то, что с сайта доступ есть... |
| Автор: yulyaT 10.6.2012, 23:08 |
| Так не проходит, в таком варианте срабатывает die('Not connected : ' . mysql_error()) Not connected : Can't connect to MySQL server on 'ххх.freetzi.com' (111) Кроме того, я думаю раз с localhost ошибка не выскакивает, значит он серверу подходит и причина в users. Предлагали вариант: $dbName = 'localhost.users'; Он тоже не работает:( |