| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > PHP: Общие вопросы > настроика PHP на Apache. |
| Автор: VasilyZ 16.12.2009, 19:06 |
| Помогите, пожалуйста настроить PHP на Apache. Устанавливаю apache_2.2.14, все работает. Но вот сконфигурировать с PHP никак не получается. Пробовал php-5.3.1 и php-5.2.11, ничего не работает. Вот скриншот сообщения об ошибке: http://img519.imageshack.us/i/99813721.jpg/ Очень прошу помогите. |
| Автор: Ипатьев 16.12.2009, 19:13 |
| странная ошибка. она точно имеет отношение к установке РНР? что гугль говорит про нее? |
| Автор: VasilyZ 16.12.2009, 19:55 |
| Дело в том, что до установки PHP Apache запускается, а после вылезает эта ошибка. Я прошу пощения, я чайник в этом деле, и я просто не знаю, что такое гугль. |
| Автор: Ипатьев 16.12.2009, 19:57 |
| это поисковик, http://google.com в него копируется текст ошибки и очень часто можно найти решение а как PHP устанавливается? Не инсталлятором, я надеюсь? Если так, то все равно работать не будет. Надо скачивать зип файл и конфигурировать руками |
| Автор: Nigel 16.12.2009, 21:04 |
| По ошибке видно, что нет доступных сокетов для соединения. Проверьте, запущены ли у вас какие-нибудь службы на 80-м порту. IIS, либо же остался какой-то из процессов апач в результате сбоя при выключении. Также посмотрите директиву Listen в настройках апач. |
| Автор: bars80080 17.12.2009, 01:11 |
| и как бы вопрос совсем не в тему: а не установлен ли случаем скайп? |
| Автор: chiffa 17.12.2009, 01:34 |
| было у меня такое када то: 1. Проверь фаевол 2. что у тебя в httpd прописано в Listen? |
| Автор: Avrely 17.12.2009, 17:52 |
| У меня была проблема что если включен skype, то apache не запускался. Конфликт портов. |