Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Базы данных под .NET > Ошибка при подключение к SQLEXPRESS


Автор: Competitor 21.5.2008, 19:10
Привет всем.
Использую SQLEXpress и Visual studio 2005.
Создал dll для получения данных из БД, тестирую ее из отдельного проекта (с использ. NUnit), всё работает, к базе подключается.
Но когда к этой dll обращается Web-сервис, крутящийся на IIS и расположенный на локальном компе, то возникает следующая ошибка:
System.Data.SqlClient.SqlException: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)
- Файерволл отключил
- в surface area configuration выставил remote connection

вот конфиг:
<connectionStrings>
<add name="OIgnatov.DataProvider.Properties.Settings.MyConnection"
connectionString="Data Source=MyComp\SQLEXPRESS;Initial Catalog=MyDB;Persist Security Info=True;User ID=MyUser;Password=MyPass"
providerName="System.Data.SqlClient" />
</connectionStrings>

плиз хелп

Автор: polundra 3.6.2008, 10:36
Похожая ситуация. VS-2005 + SQL EXpress 2005.
Проблема: невозможно подключиться к SQL-серверу с удаленного компьютера.

Настройки:
SQL Server Configuration Manager -> Protocols for SQLEXPRESS -> TCP/IP -> Свойства -> закладка IP addresses 
Ip-адрес 192.168.x.y установлен Active и Enable 
TCP Dynamic Ports: 1187
TCP Port:  <пусто>

SQL Server Surface Area Configuration 
SQL Server Surface Area Configuration  for Services and Connections -> Remote Connections
Установлено:
Local and Remote Connections, Using both TCP/IP and Name Pipes
SQL Server Browser – disable. (не нужен он)

При запуске своего приложения, подключающегося к БД  через:

ConnStr = "SERVER=MyServer\SQLEXPRESS;Database=MyBase;Integrated Security=TRUE"
MyConn.ConnectionString = ConnStr
MyConn.Open()  
Задана аутентификация Windows.

Получаю ошибку: 
An error has occurred while establishing a connection to the server.
When connection to SQL Server 2005, this failure may caused by the
fact that under the default settings SQL Server does not allow remote 
connections. (provider: SQL Network Interfaces, error 26 - Error Locating
Server/Instance Specified)

System.Data.SqlClient.SqlException

При запуске на компьютере, где сама база живет - все ОК

Пробовал указывать TCP-порт в строке подключения, например:
ConnStr = "SERVER=MyServer\SQLEXPRESS, 1433;Database=MyBase;Integrated Security=TRUE" (как советуют)
или
ConnStr = "SERVER=MyServer\SQLEXPRESS, 1187;Database=MyBase;Integrated Security=TRUE" (т.к. TCP Dynamic Ports: 1187)

В обоих случаях и на локальном компьютере получаю вышеприведенную ошибку.


Автор: polundra 3.6.2008, 14:26
Включил  SQL Server Browser – теперь другая ошибка при попытке подключения с удаленного компьютера:
An error has occured while establishing a connection to the server.
When connection to SQL Server 2005, this failure may caused by the
fact that under the default settings SQL Server does not allow remote 
connections. (provider: TCP Provider, error: 0 - Подключение не установлено,
т.к. конечный компьютер отверг запрос на соединение).
------------------------------------------------------------------------------------
Local and Remote Connections надо было установить TCP Only. Все заработало.


Автор: akizelokro 4.6.2008, 14:17
Где-то есть статья по настройке  базы SQL Express Edition для того, чтобы настроить ее для сетки. Если найду ссылку, то пропишу.

Добавлено через 9 минут и 41 секунду
http://http://support.microsoft.com/kb/914277/ru

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)